Firefox 20.0 appears to have a memory leak

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: joshua, Unassigned, NeedInfo)

Tracking

22 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Updated to Firefox 20.0
Used Firefox as usual visiting a variety of websites. Downloaded PDFs and JPGs


Actual results:

System response slowed substantially after about 10 min of Firefox 20.0 use.
Checked memory use in Task Manager. Firefox reported as using 1.47 GB.
Closed and started Firefox anew.
Experienced same slowdown behavior after about 10 min.
Checked memory use in Task Manager. Firefox reported as using 1.52 GB.


Expected results:

After several hours use, the previous rev of Firefox would typically report a maximum of 200 to 300 MB. Normal memory use after only 10 minutes would be < 100 MB.

Comment 1

5 years ago
Upgrade to Firefox 23.0.1 which is the latest version.

After that, try in safe mode (https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode) and with a clean profile (https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles).

Memory leaks can be caused by add-ons.
Flags: needinfo?(joshua)

Comment 2

5 years ago
I installed the latest Firefox 23 Beta build (Firefox Setup Stub 24.0b3.exe)and found that on just leaving the Firefox launched and active showing on my screen did not leak memory. Memory used remained steady at 156 MB.

Environment used : Windows 7 Home Basic.

Comment 3

4 years ago
WFM per reporter
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.