Lightning 2.8a1 has broken component manifests, interfaces not loaded properly, views not working

RESOLVED FIXED in 2.8

Status

Calendar
Build Config
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Matthew Turnbull [Bluefang], Assigned: Paenglab)

Tracking

({dogfood})

Lightning 2.8
dogfood

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Lightning 2.8a1 has corrupt component manifests. Both libical.manifest and icaljs.manifest have the following:

interfaces .xpt

Which is preventing them from being registered.
(Assignee)

Comment 1

5 years ago
Created attachment 792142 [details] [diff] [review]
proposed fix

This patch simply removes the #expand. Is this okay like this? I have no other manifest found which is using the #expand for this. If this is the wrong approach, I hope someone other will take the bug.

I don't know if the XPIDL_MODULE = '...' are still needed in the moz-build files and leave them unchanged.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #792142 - Flags: review?(philipp)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 906675
Severity: normal → blocker
Target Milestone: --- → 2.8
The expand thing is for the preprocessor and is an alternative for that #filter line found in other files. Not sure this is the right solution, does it work?
(Assignee)

Comment 4

5 years ago
Yes, with this the manifests are looking normal and Lightning is usable again.
(Assignee)

Comment 5

5 years ago
Forgot to write, it looks as the preprocessor can't find the variable __XPIDL_MODULE__. I only expanded this variable and wrote it directly into the manifest.
There have been changes to the XPIDL code in comm-central lately: Bug 850380

I believe, it has to do with that.
After Updating the repo, I found it is also broken in Windows
OS: Linux → All
Hardware: x86_64 → All

Updated

5 years ago
Keywords: dogfood
Comment on attachment 792142 [details] [diff] [review]
proposed fix

This works as far as I can see. I'm not sure if this is the best long term solution or not, but I'd suggest taking this for now it to get comm-central working again.
Attachment #792142 - Flags: feedback+
Comment on attachment 792142 [details] [diff] [review]
proposed fix

Ok, lets do it. Please leave the bug open after checkin.
Attachment #792142 - Flags: review?(philipp) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Whiteboard: Don't close the bug
Whiteboard: Don't close the bug → [leave-open]

Updated

5 years ago
Summary: Lightning 2.8a1 has broken component manifests → Lightning 2.8a1 has broken component manifests, interfaces not loaded properly, views not working
Version: Trunk → Lightning 2.8

Comment 11

5 years ago
Problem is fixed, therefore no longer blocking.
Severity: blocker → normal

Updated

5 years ago
Attachment #792142 - Flags: checkin+
(Assignee)

Comment 13

4 years ago
This bug is fixed but still open to find a maybe better/cleaner solution. The actual problem is bug 916537.
This hack will probably stay here until we throw out libical, therefore I suggest we close this issue and create a new one in case we want to fix it differently.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [leave-open]
You need to log in before you can comment on or make changes to this bug.