Closed Bug 906398 Opened 6 years ago Closed 5 years ago

B2G RIL: move CellBroadcastMessage to WebIDL

Categories

(Firefox OS Graveyard :: RIL, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(tracking-b2g:backlog)

RESOLVED DUPLICATE of bug 864484
tracking-b2g backlog

People

(Reporter: vicamo, Assigned: bevis)

References

Details

(Whiteboard: [priority])

Moving CellBroadcastMessage to WebIDL doesn't block bug 888591, so breaking down the task into two parts.

Moving CellBroadcastEvent won't be necessary because we don't need that for bug 864484.
Depends on: 865403
Component: DOM: Device Interfaces → RIL
Product: Core → Boot2Gecko
Blocks: 981845
Put this bug into backlog.
blocking-b2g: --- → backlog
No longer blocks: 864484
Depends on: 864484
Same as bug 994461 comment 3.
Flags: needinfo?(htsai)
assign to myself to follow up.
Assignee: nobody → btseng
(In reply to Bobby Holley (:bholley) from comment #2)
> Same as bug 994461 comment 3.

(In reply to Bevis Tseng [:bevistseng] (btseng@mozilla.com) from comment #3)
> assign to myself to follow up.

Hi Bobby,
We've seen this as [priority]. Thanks Bevis to follow this up. 

However, please kindly understand that 2.1 feature scope is locked down and our team doesn't have enough bandwidth to these late requests. It's hardly to be done by the end of August.
Flags: needinfo?(htsai)
Whiteboard: [priority]
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #4)
> However, please kindly understand that 2.1 feature scope is locked down and
> our team doesn't have enough bandwidth to these late requests. It's hardly
> to be done by the end of August.

That's fine. The issue is mostly that these old-style APIs are a lingering security threat, and we need to apply some pressure to get traction from the wide spectrum of teams that own the various APIs to fix their stuff. I know you folks are on a tight schedule, so doing it in September is fine too, so long as somebody commits to getting it done.

For what it's worth, I expect that this conversion will be a very straightforward process, and shouldn't take more than 45 minutes for someone familiar with the code. Please let me know if you run into any issues with the WebIDL machinery - I'm happy to provide guidance and fix any bugs there if needed.

Thanks for prioritizing it!
Duplicate of this bug: 859808
Blocks: 999307
While implementing bug 864484, 1 necessary modification is to define CellBroadcastMessage in C++ implementation.
To reduce the effort for implementation and review of CellBroadcastMessage implementation,
I'd like combine this bug to Patch Part 2 of bug 864484 to finish this task at once.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 864484
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.