crash in mozilla::layers::DeprecatedTextureHostDXGID3D11::UpdateImpl(mozilla::layers::SurfaceDescriptor const&, nsIntRegion*, nsIntPoint*)

RESOLVED FIXED in mozilla26

Status

()

--
critical
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: jimm, Assigned: nrc)

Tracking

({crash, regression})

26 Branch
mozilla26
x86
Windows 8.1
crash, regression
Points:
---

Firefox Tracking Flags

(firefox25 unaffected, firefox26 affected)

Details

(Whiteboard: [metro-crash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
https://crash-stats.mozilla.com/report/list?product=MetroFirefox&range_value=7&range_unit=days&date=2013-08-18&signature=mozilla%3A%3Alayers%3A%3ADeprecatedTextureHostDXGID3D11%3A%3AUpdateImpl%28mozilla%3A%3Alayers%3A%3ASurfaceDescriptor+const%26%2C+nsIntRegion*%2C+nsIntPoint*%29&version=MetroFirefox%3A26.0a1

0 	xul.dll 	mozilla::layers::DeprecatedTextureHostDXGID3D11::UpdateImpl(mozilla::layers::SurfaceDescriptor const &,nsIntRegion *,nsIntPoint *) 	gfx/layers/d3d11/TextureD3D11.cpp
1 	xul.dll 	mozilla::layers::ContentHostDoubleBuffered::UpdateThebes(mozilla::layers::ThebesBufferData const &,nsIntRegion const &,nsIntRegion const &,nsIntRegion *) 	gfx/layers/composite/ContentHost.cpp
2 	xul.dll 	mozilla::layers::CompositableParentManager::ReceiveCompositableUpdate(mozilla::layers::CompositableOperation const &,std::vector<mozilla::layers::EditReply,std::allocator<mozilla::layers::EditReply> > &) 	gfx/layers/ipc/CompositableTransactionParent.cpp
3 	xul.dll 	mozilla::layers::LayerTransactionParent::RecvUpdate(nsTArray<mozilla::layers::Edit> const &,mozilla::layers::TargetConfig const &,bool const &,nsTArray<mozilla::layers::EditReply> *) 	gfx/layers/ipc/LayerTransactionParent.cpp
4 	xul.dll 	Pickle::ReadBool(void * *,bool *) 	ipc/chromium/src/base/pickle.cc
5 	dxgi.dll 	CDXGISwapChain::Present(unsigned int,unsigned int) 	
6 	mozglue.dll 	arena_dalloc_small 	memory/mozjemalloc/jemalloc.c
7 	mozglue.dll 	arena_dalloc 	memory/mozjemalloc/jemalloc.c
8 	mozglue.dll 	arena_ralloc 	memory/mozjemalloc/jemalloc.c
9 	xul.dll 	std::vector<mozilla::ipc::RPCChannel::RPCFrame,std::allocator<mozilla::ipc::RPCChannel::RPCFrame> >::push_back(mozilla::ipc::RPCChannel::RPCFrame &&) 	c:/tools/msvs10/vc/include/vector
10 	xul.dll 	mozilla::ipc::SyncChannel::OnDispatchMessage(IPC::Message const &) 	ipc/glue/SyncChannel.cpp
11 	xul.dll 	MessageLoop::RunTask(Task *) 	ipc/chromium/src/base/message_loop.cc
12 	xul.dll 	MessageLoop::DoWork() 	ipc/chromium/src/base/message_loop.cc
13 	xul.dll 	base::MessagePumpDefault::Run(base::MessagePump::Delegate *) 	ipc/chromium/src/base/message_pump_default.cc
14 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc
15 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
16 	xul.dll 	base::Thread::ThreadMain() 	ipc/chromium/src/base/thread.cc
17 	xul.dll 	`anonymous namespace'::ThreadFunc(void *) 	tools/profiler/platform-win32.cc
18 	kernel32.dll 	BaseThreadInitThunk 	
19 	ntdll.dll 	__RtlUserThreadStart 	
20 	ntdll.dll 	_RtlUserThreadStart
(Assignee)

Comment 1

5 years ago
Looks like the call to OpenSharedResource is failing and so mTextures[0] is null. I don't know why that would happen. The msdn page (http://msdn.microsoft.com/en-us/library/windows/desktop/ff476531%28v=vs.85%29.aspx) doesn't suggest any reason for intermittent failure. Another possibility is that we are just passing around a null or bad handle to the texture.

jimm - do you recall what you were doing when the crash happened?
Flags: needinfo?(jmathies)
(Assignee)

Comment 2

5 years ago
Also, has this happened recently? Nothing in the last ten days in the crash stats so maybe something else we've done has fixed it.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 890610
(Reporter)

Comment 4

5 years ago
(In reply to Nick Cameron [:nrc] from comment #1)
> Looks like the call to OpenSharedResource is failing and so mTextures[0] is
> null. I don't know why that would happen. The msdn page
> (http://msdn.microsoft.com/en-us/library/windows/desktop/ff476531%28v=vs.
> 85%29.aspx) doesn't suggest any reason for intermittent failure. Another
> possibility is that we are just passing around a null or bad handle to the
> texture.
> 
> jimm - do you recall what you were doing when the crash happened?

I filed this off crashstats, I haven't reproduced.

(In reply to Nick Cameron [:nrc] from comment #2)
> Also, has this happened recently? Nothing in the last ten days in the crash
> stats so maybe something else we've done has fixed it.

Yep, looks like it went away on 8/23.
Flags: needinfo?(jmathies)
(Assignee)

Comment 5

5 years ago
Created attachment 796884 [details] [diff] [review]
don't assume OpenSharedResource always suceeds

Some speculative guarding against crashing if this situation occurs in the future.
Assignee: nobody → ncameron
Attachment #796884 - Flags: review?(bas)
Comment on attachment 796884 [details] [diff] [review]
don't assume OpenSharedResource always suceeds

Review of attachment 796884 [details] [diff] [review]:
-----------------------------------------------------------------

I don't really object to this but we should -really- find out why this happens. Also, check the return code of OpenSharedSource SUCCEEDED as well as checking the texture to be !NULL.
Attachment #796884 - Flags: review?(bas) → review+

Comment 8

5 years ago
https://hg.mozilla.org/mozilla-central/rev/ca1ff26fc797
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.