Incorrect caracter translation between 2 bytes and 1 byte

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: lferro, Assigned: nhottanscp)

Tracking

({qawanted})

Trunk
x86
Windows NT
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
BuildID:    2001070404

When receiving messages from acentuated languages like portugues, the 
characters aren't converted correctly...

Reproducible: Always
Steps to Reproduce:
1. Change computer keyboard to an acentuated keyboard
2. Send a message with accetuated characters
3. receive it

Actual Results:  podem ver o que se passa, please?
já agora, vou fazer uma apresentação de e-telereport.com às 11 horas.
portem-se bem, okis? e não me cortem o programa a meio da 
apresentação  [:-)] 
obrigada e beijos



Expected Results:  podem ver o que se passa, please?
já¡ agora, vou fazer uma apresentação de e-telereport.com às 11 horas.
portem-se bem, okis? e não me cortem o programa a meio da apresentação  [:-
)] 
obrigada e beijos



Seams to me that convertion between 2 characters and 1 character is failing...
(Assignee)

Comment 1

17 years ago
Could you attach screen shots of expected and actual cases?
Also please send the mail to nhotta@netscape.com, ji@netscape.com,
marina@netscape.com, thanks.

Comment 2

17 years ago
lferro, are you using portugese keyboard or you are switching input on the
console to the portugese one? Are you on portugese WinNT or EN WinNT? Thanks for
the additional info.
(Reporter)

Comment 3

17 years ago
I'm using windows 2000 professional MSDN edition with IE5.0 updated and with
SP2. The windows version is EN. The keyboard and regional settings are PT
Standard and PT Portugal.

Comment 4

17 years ago
Thanks for the update. I am on Win2K, i switched my keyboard to PT ( i tried
french keyboard as well) and when i am sending for example "çççç" i see them
displayed correctly after i've get mail. Would you please attach the screen shot
and the specific mail so we can reproduce it here? Thanks.
(Reporter)

Comment 5

17 years ago
Can't soon... i've working on another facility and only in august i will return
to the place where the computer with the faulty mail is. BTW, the sender machine
is a Windows 98 box (not sure which version/language/configuration but can ask
when there).
(Assignee)

Comment 6

17 years ago
put 'qawanted', need more info, screen shot
Keywords: qawanted

Comment 7

17 years ago
mark this bug as workforme since we cannot reproduce it in house and lack of
information. Please reopen after you can reproduce it and supply information
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 8

17 years ago
Marked it verified. Please feel free to reopen it if you see the problem again
on the latest build.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.