Opening a <select> box in a panel erases all panel content

RESOLVED DUPLICATE of bug 886329

Status

Add-on SDK
General
RESOLVED DUPLICATE of bug 886329
4 years ago
4 years ago

People

(Reporter: orthecreedence, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 791876 [details]
panel_select.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

I opened a panel with the following HTML:

<!DOCTYPE html>
<html>
	<head>
		<meta http-equiv="Content-Type" content="test/html; charset=utf-8">
		<meta http-equiv="Content-Language" content="en">
	</head>
	<body>
		<h1>About</h1>
		<form>
			<select name="board">
				<option value="1bce8192">board 1</option>
				<option value="1bce8169">board 2</option>
			</select>
		</form>
	</body>
</html>

This panel has no content scripts attached. It is attached to a toolbar button (deprecated, I know). Removing the attachment does *not* fix the issue. 

I have noticed this on both Firefox 23.0.1 in linux and Firefox 23.0.1 in Windows 7 (both x86_64). It renders my add-on unusable.



Actual results:

I open the panel via a toolbar button with a menu. I click the menu item and the panel shows up. I click the select element to open it, and on clicking, the entire contents of the panel disappears. The options in the select appear on the very left of the screen (off the browser window). Selecting one makes the options disappear, and none of the original content comes back into view. The panel is still open, but has no content.

Note that closing then re-opening the panel still does not show any of the lost content.


Expected results:

The panel's content should be unaffected by a select element being opened within the panel.
(Reporter)

Updated

4 years ago
Hardware: All → x86_64
(Reporter)

Comment 1

4 years ago
I forgot to mention: this was working fine in FF 22, but the recent update to 23 is what affected this.

Thanks!
Hardware: x86_64 → All

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 886329
You need to log in before you can comment on or make changes to this bug.