If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Composer 2.20 corrupts HTML in ways 2.19 didn't

RESOLVED WORKSFORME

Status

SeaMonkey
Composer
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Jon Roland, Unassigned)

Tracking

SeaMonkey 2.20 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 791896 [details]
dub-dom.html

User Agent: Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20100101 Firefox/23.0 SeaMonkey/2.20 (Beta/Release)
Build ID: 20130803195701

Steps to reproduce:

Opened page http://constitution.org/proppriv/e-domain/dub-dom.html for edit, made changes, and saved.


Actual results:

1. The javascript that produces the ads was altered to convert absolute URLs into relative URLs with the creation of supporting files and a directory that should not be created. The scripts only work by accessing the remote site.
2. Several of the HTML codes were replaced with garbage, specifically  » and —
3. This behavior was not observed with the previous version 2.19, so something got broken. It was observed several versions back, in late 2011.


Expected results:

Editing the body of the text should have been the only changes made. All the existing HTML should have been left alone.

Comment 1

4 years ago
I'm not seeing any change?

I took this line
> <big>Dubious Domain<br>

And changed it to
> <big>Dubious Domain219<br>
in SeaMonkey 2.19 & saved the page as html.

And changed it to
> <big>Dubious Domain220<br>
in SeaMonkey 2.20 & saved the page as html.

Comparing the two pages, the only difference is /219/220/.

Comment 2

4 years ago
Opened page in current trunk version, changed a couple of letters, saved it, observed differences:
1) &raquo; and &#8212; in original file became > and - respectively, so problem is currently fixed
2) Some minor attributes rearrangements in td tag, nothing critical, setting close date to somewhere close to 2.23 release
Whiteboard: closeme WFM 2013-12-15
(Reporter)

Comment 3

4 years ago
All of the problems don't show up by just loading the file from the local drive and saving it again using the Composer. It is only after making certain changes and saving it that one gets a save that alters the main file and creates several support files that are definitely not desired. I am attaching the corrupted file and the support files in the subdirectory dub-dom-bad_files with files donatre.html and show_ads.js. In that directory is a subdirectory donate_data with the file blue-small.gif
(Reporter)

Comment 4

4 years ago
Created attachment 794484 [details]
dub-dom-bad.html
(Reporter)

Comment 5

4 years ago
Created attachment 794486 [details]
donate.html
(Reporter)

Comment 6

4 years ago
Created attachment 794487 [details]
show_ads.js
(Reporter)

Comment 7

4 years ago
Created attachment 794488 [details]
blue-small.gif
(Reporter)

Comment 8

4 years ago
The intended use is to download an HTML file from the remote site using ftp or a method of saving that does not alter links or create support files, because the intent is to edit it and ftp it back up to the remote server for viewing, not viewing from the local drive except in the composer window. That means support files will only appear if their links are absolute rather than relative, although those should work.

The main desire is that the adsense ads not be altered, but continue to work before and after editing other parts of the page and saving the result to be ftp'd up to the server again.

Comment 9

4 years ago
Check this build - http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-comm-central-trunk/seamonkey-2.23a1.en-US.linux-i686.tar.bz2 and see if problem is present there
(Reporter)

Comment 10

4 years ago
Tried  http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-comm-central-trunk/seamonkey-2.23a1.en-US.linux-i686.tar.bz2 and the problem remains, both for altering external links and for the special characters.
(Reporter)

Comment 11

4 years ago
Some target release needs to be tested on a file containing EVERY HTML character code. That should be standard QA procedure.

Comment 12

4 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Whiteboard: closeme WFM 2013-12-15
You need to log in before you can comment on or make changes to this bug.