UI, bad render with hardware acceleration

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: simon.blandford, Assigned: dcone)

Tracking

Trunk
Future
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062815

Using a Dell Optiplex GX1 GX1MTDSK500+ which uses an ATI 3D Rage Pro AGP 2X it
is necessary to reduce the graphics hardware acceleration or the user interface
breaks up and leaves black-striped artifacts. This is particularly bad when
using the Aqua skin but also noticible on the modern skin.

Reproducible: Always
Steps to Reproduce:
1. Install W2000 on Optiplex GX1
2. Install Mozilla 0.9.2 and modern or aqua skin
3. Just use bookmarks, buttons etc.

Actual Results:  Rendering is broken. No other program I run has this problem so
reducing hardware acceleration *should* be unecessary.

Auqa skin can be got from  http://www.simweb.net/eric/projects/Aqua/
 . The version on themes.org doesn't work.
Reporter: Are you using the latest version of your video card's drivers?

Comment 2

18 years ago
--> Compositor
Assignee: mpt → kmcclusk
Component: User Interface Design → Compositor
QA Contact: zach → petersen
Hmm, that sounds more like a bad graphic card driver than Mozilla's fault...

Reporter: Can you retest this with the newest graphic card driver and a new
Mozilla build ?

Comment 4

17 years ago
I suggest retesting this with the latest Rage drivers:
http://support.ati.com/products/pc/ragepro/win2k/ragepro_win2k_drivers.html

as well as with Windows 2000 sp2:
http://www.microsoft.com/windows2000/downloads/servicepacks/sp2/default.asp

I've run into a few problems with odd video behavior under Windows 2000 with my
older Dell system.  I'm using Mozilla build 2001091003 under Windows 2000sp2
without issue (with hardware acceleration set to max).  Service Pack 2 resolved
some odd video issues I'd had early with other programs that prevented me from
running hardware acceleration at max.
(Reporter)

Comment 5

17 years ago
I also have the same problem at home with W2000 SP2 on an ASUS CUSL2 
motherboard with a Matrox G200 AGP using the very latest drivers from Matrox. 
It is allot worse than the Dell here at work, the screen disintegrates into 
something looking like the Matrix. I have to restart the machine from the 
keyboard as I can't see the mouse anymore. I never had this problem with any 
other application before Mozilla and also Netscape 6.1.
Again, switching off bitmap accelleration fixes it.
As this looks to be video-card related, -> INVALID?
(Reporter)

Comment 7

17 years ago
Two different video cards? Two different machines?

Comment 8

17 years ago
there is a possibility that the 2 cards have bugs and/or the 2 drivers have bugs

BTW, reporter, have you tested this in a more recent build/milestone? Is it only
with the Aqua skin and Modern skin? Could you test with the classic skin?

Could this be due to the type of images used in those skins? (i.e. colour depth?)

Comment 9

17 years ago
I have a rage mobile pro in my Dell with the latest drivers and see no problems
with the UI.
(Reporter)

Comment 10

17 years ago
Created attachment 52490 [details]
Example of artifacts on Dell Optiplex GX1 with new Rage driver.
(Reporter)

Comment 11

17 years ago
OK, I just tried a new ATI Rage Pro driver on the Dell computer I use at work. 
I am using Mozilla 0.9.4. I have attached some of the artifacts still visible, 
ATIRagePro-Dell.zip.
The new driver version is 5.0.2195.4018 just downloaded from their website.

I get artifacts on and under the URL bar with the Modern skin only and also 
with the vertical scroll bar with both the Modern and Classic skins. The Aqua 
skin has artifacts around the URL bar. The scroll bar is broken since Mozilla 
0.9.4 and how appears horizontal (see PNG file).

I'll get back to you regarding the ASUS/G200 machine at home when I next use 
Windows (which isn't so often now).

Regards,
Simon B.

Updated

17 years ago
Blocks: 104992

Comment 12

17 years ago
***spam***

This bug has been marked as a dependency of bug 104992, which is a tracking bug
for a possible ATI videocard issue.
No longer blocks: 104992

Updated

17 years ago
Blocks: 104992
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 13

17 years ago
*** Bug 108070 has been marked as a duplicate of this bug. ***
*** Bug 150857 has been marked as a duplicate of this bug. ***
*** Bug 151019 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
Confirming #5; "switching off bitmap accelleration fixes it."

With a Dell L400 (ATI RAGE MOBILITY-M AGP2X)
-> dcone
Assignee: kmcclusk → dcone
Status: ASSIGNED → NEW

Comment 18

16 years ago
This sounds very much like an issue some ATI cards have with WinGimp:

From http://www.gimp.org/~tml/gimp/win32/

"Many people with ATI Rage Pro cards have complained about display errors. It
seems that this is a known problem with the drivers for these cards, and can be
worked around by setting DEVBMP=0 in the [display] section of the Windows
system.ini file, like this:

[display] 
DEVBMP=0 
"

There is also a release of drivers from ATI which mentions fixes for Mozilla in
the release notes ( commented on in bug 120893 )

Comment 19

16 years ago
*** Bug 177296 has been marked as a duplicate of this bug. ***

Comment 20

16 years ago
*** Bug 182731 has been marked as a duplicate of this bug. ***

Comment 21

16 years ago
*** Bug 187769 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Component: GFX → GFX: Win32

Comment 22

16 years ago
Hey, I'm experiencing the very same problem with a Matrox G450 
card on windows2000 using certified drivers. It's the only application
with this problem. (using 1.5 alpha, but the same problem occurs
with 1.4, don't know about earlier versions...)

Comment 23

15 years ago
Created attachment 129577 [details]
linux screenshot 

This bug also occurs under linux

Comment 24

14 years ago
*** Bug 248745 has been marked as a duplicate of this bug. ***
No new dupes since 2004, I think this is a bug in the video driver and it should work with modern video cards/drivers
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.