[wasabi] Unable to show the carrier's name but only MCC+MNC number.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Settings
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: Enpei, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [FT:RIL])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
With APTG UIM inserted on device, it can only show 46605 on lockscreen, description and carrier name of Cellular & Data setting, and notification bar. 46605 is MCC + MNC of APTG network.

Bug description:
* Build Number                
Gaia:     8fd7f5656d75f6c7ce73a93addd21e7f33a7943f  
 B-D     2013-08-19 00:22:59                       
Gecko:  f91fb63da2d6cead5c03f8d075afce68d7fe1921                                        
BuildID   20130819061633                        
Version   26.0a1  

* Reproduce Steps
Insert APTG UIM.

* Expected Result
Either shows "亞太電信" or "APTG" or "APBW" as its carrier name.

* Actual Result
46605.
Depends on: 904984
No longer depends on: 904984

Comment 1

4 years ago
With Enpei's APTG sim card, I can see this issue. But it is not happened with another APTG sim card.

Comment 2

4 years ago
Created attachment 793870 [details]
logcat_did_not_show_carrier_name.txt

Attach logcat

Comment 3

4 years ago
With the issue sim card, all of system id are 0, we can not match any network in EF_CDMAHOME. So that we display the name from operator, 46605, instead of displaying the name in EF_SPN.

01-10 04:20:13.785   198   420 I Gecko   : RIL Worker[0]: CDMAHome system id: [0,0,0]
01-10 04:20:13.785   198   420 I Gecko   : RIL Worker[0]: CDMAHome network id: [65535,0,0]

08-22 14:42:50.737   198   420 I Gecko   : RIL Worker[0]: Operator: 46605,,46605

Comment 4

4 years ago
According to comment #3, it is caused by SIM card does not provide correct information, mark as WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 5

4 years ago
Hi Edgar,

As we talked, I still hope that UI can show carrier's name even based on 46605 info. Other reference phone can still display correct carrier's name even with same UIM card. Please help to change issue component field if current "Gaia::Settings" is not suitable. Thank you.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
FYI, with the sim card we are not able to get correct mcc and mnc code from operatorvariant.mcc and operatorvariant.mnc.
(Reporter)

Updated

4 years ago
Whiteboard: [FT:RIL]
(Reporter)

Comment 7

4 years ago
Hi Arthur,

Can you check bug 927324, maybe they are identical and can help on this one?
Flags: needinfo?(arthur.chen)
Enpei, thanks for the information. I think bug 927324 is not related to this one as bug 927324 seems a rendering issue.
Flags: needinfo?(arthur.chen)

Comment 9

4 years ago
(In reply to Enpei from comment #7)
> Hi Arthur,
> 
> Can you check bug 927324, maybe they are identical and can help on this one?
                ^^^^^^^^^^
I think you are talking about bug 927234. :)
And after offline discussion with you and Arthur, this issue is not related to bug 927234, thanks.

Comment 10

4 years ago
(In reply to Enpei from comment #5)
> Hi Edgar,
> 
> As we talked, I still hope that UI can show carrier's name even based on
> 46605 info. Other reference phone can still display correct carrier's name
> even with same UIM card. Please help to change issue component field if
> current "Gaia::Settings" is not suitable. Thank you.

Hi Enpei,

The carrier's name is provided by following information:
1. Carrier's information stored in sim card.
2. The result of RIL_REQUEST_OPERATOR.

As I mentioned in comment #3, sim card does not provide correct information, so we use the result of RIL_REQUEST_OPERATOR [1], but the modem replies '46605' [2]. And we got the same result in wasabi with Android. So we need modem side help to check dose they provide correct information about operator's name, thank you.

[1] https://github.com/mozilla-b2g/platform_hardware_ril/blob/master/include/telephony/ril.h#L1391
[2] Please see comment #3.
(Reporter)

Comment 11

4 years ago
Hi Ivan,

One more bug analyzed as modem problem, could you include this one with other 4 POVB bugs and see if ZTE could support debugging them?
Flags: needinfo?(itsay)
Whiteboard: [FT:RIL] → [FT:RIL, POVB]

Comment 12

4 years ago
Already send the email to partner to look for help already. Since Wasabi is the old model from 2 years ago and currently not the official project for our partner, partner won't have timely support on this one. Partner said they can help on the issue analysis but won't be able to provide fix even the issue is identified in the vendor's build.
Flags: needinfo?(itsay)
(Reporter)

Comment 13

4 years ago
Hi Edgar,

I got Qualcomm ril and updated with latest v1.2 build, it can show "亞太電信" correctly. 
Same SIM with same code except using mozril will only show 46605. Could you check the bug again? Is it still modem problem or something we can do from MozRIL?

Gaia:     8ff13cf43d185104a000bab68f5eef589b5d8684
Gecko:    41e8c46cb1b8b9b3058b1cbf6525c020bebfc4f0
BuildID   20131120031537
Version   26.0
Flags: needinfo?(echen)
Whiteboard: [FT:RIL, POVB] → [FT:RIL]
(Reporter)

Comment 14

4 years ago
Created attachment 8335062 [details]
log from Qualcomm ril.
(Reporter)

Comment 15

4 years ago
Created attachment 8336514 [details]
screenshot of wasabi with qcril

Comment 16

4 years ago
The cdma home (sid,nid) stored in the sim card are (0,65535) (0,0) (0,0).
--
01-10 04:20:13.785   198   420 I Gecko   : RIL Worker[0]: CDMAHome system id: [0,0,0]
01-10 04:20:13.785   198   420 I Gecko   : RIL Worker[0]: CDMAHome network id: [65535,0,0]
--

And the sid and nid from the network is (13505,33)
--
Queuing voiceRegistrationState network info message: {"regState":1,"state":"registered","connected":true,"roaming":false,"emergencyCallsOnly":false,"cell":{"gsmLocationAreaCode":-1,"gsmCellId":-1,"cdmaBaseStationId":0,"cdmaBaseStationLatitude":0,"cdmaBaseStationLongitude":0,"cdmaSystemId":13505,"cdmaNetworkId":33},"radioTech":4,"type":"is95a","rilMessageType":"voiceregistrationstatechange"}
--

According to the spec, C.S0005 sec. 2.6.5.2/2.6.5.3,
--
The mobile station has a list of one or more home (non-roaming) (SID, NID) pairs. A mobile
station is roaming if the stored (SIDs, NIDs) pair (received in the System Parameters
Message on the Paging Channel, or the ANSI-41 System Parameters Message on the Primary
Broadcast Control Channel) does not match one of the mobile station’s non-roaming (SID,
NID) pairs.
--

(13505,33) can not match any (sid,nid) pairs stored in sim card, so we use the operator name, "46605", which is from the network.
--
08-22 14:42:50.737   198   420 I Gecko   : RIL Worker[0]: Operator: 46605,,46605
08-22 14:42:50.737   198   420 I Gecko   : RIL Worker[0]: updateDisplayCondition: isDisplayNetworkNameRequired = false
08-22 14:42:50.737   198   420 I Gecko   : RIL Worker[0]: updateDisplayCondition: isDisplaySpnRequired = false
08-22 14:42:50.737   198   420 I Gecko   : RIL Worker[0]: Queuing operator network info message: {"rilMessageType":"operatorchange","longName":"46605","shortName":"","mcc":"466","mnc":"05"}
--

It follows the spec and the android version has the same behavior too.

Comment 17

4 years ago
(In reply to Enpei from comment #14)
> Created attachment 8335062 [details]
> log from Qualcomm ril.

Check the log of QCRIL, the sid and nid from the network is (13505,33)
---
11-20 11:50:20.627 I/Gecko   (  201): -*- QCContentHelper_QC_B2G: sendMessage to content process: RIL:VoiceInfoChanged{ connected : true, emergencyCallsOnly : false, roaming : false, type : '1xrtt', signalStrength : -61, relSignalStrength : 100, network : { mcc : '466', mnc : '05', longName : '46605', shortName : null,  }, cell : { gsmLocationAreaCode : -1, gsmCellId : -1, cdmaBaseStationId : 2019, cdmaBaseStationLatitude : 360515, cdmaBaseStationLongitude : 1750597, cdmaSystemId : 13505, cdmaNetworkId : 33,  }, state : 'registered',  }
---

And the operator name from the network is "46606" as well.
--
11-20 11:50:28.053 I/Gecko   (  201): -*- QCContentHelper_QC_B2G: sendMessage to content process: RIL:VoiceInfoChanged{ connected : true, emergencyCallsOnly : false, roaming : false, type : 'evdob', signalStrength : -61, relSignalStrength : 87, network : { mcc : '466', mnc : '05', longName : '46605', shortName : null,  }, cell : { gsmLocationAreaCode : -1, gsmCellId : -1, cdmaBaseStationId : 2019, cdmaBaseStationLatitude : 360515, cdmaBaseStationLongitude : 1750597, cdmaSystemId : 13505, cdmaNetworkId : 33,  }, state : 'registered',  }
--

But have no idea why QCRIL marks |isDisplaySpnRequired| to true even (sid,nid) of network is not in list of CDMA HOME, as I mention in comment #16, according to spec, it seems we should use the name from the network.

Hi Anshul, could you kindly provide some information about the behavior of QCRIL for above case? or do I miss any thing about the spec? Thanks in advance.
Flags: needinfo?(echen) → needinfo?(anshulj)

Comment 18

4 years ago
Edgar, since QCRIL is showing the expected operator name I see no action item on us.
Flags: needinfo?(anshulj)

Comment 19

4 years ago
Close as WONTFIX according to comment#16, I think OEM can have their own fix for this case. Thank you.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.