[B2G][Helix][CardView][zhaotao]the preview card of gallery is all black

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System
P2
normal
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: lecky, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; aff-kingsoft-ciba; Zune 4.7)

Steps to reproduce:

1.open gallery app
2.tap home button to exit
3.long tap home button to show task switch view


Actual results:

in step 3,in the task switch ui,the preview of gallery app is all black


Expected results:

the preview of gallery app should be the thumbnail of gallery app,not all black
(Reporter)

Updated

5 years ago
Component: General → Gaia::Gallery
Priority: -- → P2
This bug is confirmed. I can reproduce it with m-c/master. It looks like not only gallery is affected. Apps with lots images shown are also affected. It seems the gecko issue. Besides all back cases, I had suffered a partial updated screen which is the gray grids and with black at right most column.

The simplified STR can be:
1. open gallery app or other apps with multiple images.
2. long press home button to show card view.
3. tap the app again. If not affected, redo it from 1.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 792638 [details]
screenshot of marketplace.

Besides gallery, this attachment is the screenshot of market place.
If this bug happened, you can still tap any items on the screen. For example, in gallery app, you may tap any place to have the fullscreen view of that item, and the screen is still black, too. After doing that, long pressing home button shows the correct screenshot on the card view. That's funny, blind choosing.
Hi Lecky and John,

I think you guys are talking about two different bugs. In comment 1, John has clicked into the app through the card_view, but Lecky seems not.

Could you confirm?
Flags: needinfo?(lecky.wanglei)
Flags: needinfo?(johu)
Hi George, 

If Lecky doesn't tap the card_view, it is two bugs. We need the confirmation from Lecky. Thanks for your reminding.
Flags: needinfo?(johu)
(Reporter)

Comment 6

5 years ago
Hi,george and john,

I haven't clicked into the gallery app through the card_view,

I think there are two different bugs.
Flags: needinfo?(lecky.wanglei)
Attachment #792638 - Attachment is obsolete: true
Since we separated two bugs, I make the attachment obsoleted and move it to bug 909181.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → hd?

Updated

4 years ago
Summary: [B2G][Helix][Taskswitch][zhaotao]the preview of gallery is all black → [B2G][Helix][CardView][zhaotao]the preview card of gallery is all black
(Reporter)

Updated

4 years ago
Severity: normal → blocker
This is reproduced on other v1.1 devices.

To see this bug, card view must not have been triggered from within gallery app. Otherwise kill gallery app before performing STR in comment 0.

bumping to koi? as this does not seem to be a release blocking problem but would be nice to be solved.
blocking-b2g: hd? → koi?

Updated

4 years ago
blocking-b2g: koi? → koi+
At least on inari, there seems to be a timing component to this bug. If I tap the Gallery app card with about a second of switching to card view, I almost always get the black screen. But if I wait a little bit, the card view of the Gallery seems to "adjust" itself, and then tapping brings the app back properly.
blocking-b2g: koi+ → koi?

Comment 11

4 years ago
Looks like this was accidentally set back to koi? in comment 10.
blocking-b2g: koi? → koi+
(Reporter)

Comment 12

4 years ago
hi,wayne,this issue will be fixed on V1.2,right?

hi,beatriz,can you accept this?
Flags: needinfo?(wchang)
(Reporter)

Updated

4 years ago
Flags: needinfo?(brg)
We are accept the fix in v1.2.
Flags: needinfo?(brg)

Updated

4 years ago
Flags: needinfo?(wchang)
I am going check what is happening.
Assignee: nobody → sotaro.ikeda.g
(Reporter)

Updated

4 years ago
Severity: blocker → normal
Sotaro,

Please provide an ETA (time that it will take) for the fix to land.
Flags: needinfo?(sotaro.ikeda.g)
QA,

Please check to see if the bug is reproducible in devices - Buri/ Leo/ Helix.

Please provide results for each device and provide update if this is device specific or even timing specific.

Thanks.
Keywords: qawanted
on b2g v1.2 hamachi, the problem seems to happen to almost all application. Just Gallery app is easier to reproduce it.
Flags: needinfo?(sotaro.ikeda.g)
When the problem happens, CanvasRenderingContext2D::DrawWindow() was always failed at the following.

>    nsRefPtr<gfxImageSurface> img = drawSurf->GetAsReadableARGB32ImageSurface();
>    if (!img || !img->Data()) {
>      error.Throw(NS_ERROR_FAILURE);
>      return;
>    }


https://hg.mozilla.org/releases/mozilla-b2g26_v1_2/file/e463fc6c3bc4/content/canvas/src/CanvasRenderingContext2D.cpp#l3282
DrawWindow()'s arguments 'w' and 'h' were 0.

CanvasRenderingContext2D::DrawWindow(nsIDOMWindow* window, double x,
                                     double y, double w, double h,
                                     const nsAString& bgColor,
                                     uint32_t flags, ErrorResult& error)
BrowserElementChildPreload.js calls CanvasRenderingContext2D::DrawWindow() in BrowserElementChild._takeScreenshot(). In the function, both content.innerWidth and content.innerHeight were 0.
Created attachment 826116 [details] [diff] [review]
temporary patch for v1.2 - always reisze in openWindow()

This is a temporary patch.
By attachment 826116 [details] [diff] [review], I do not see a problem Comment 19. And I do not see all black.
(In reply to Preeti Raghunath(:Preeti) from comment #15)
> Sotaro,
> 
> Please provide an ETA (time that it will take) for the fix to land.

From Comment 19, it is not a graphics problem. It seems better to ask system app engineer.
Un-assign self from Comment 22.
Assignee: sotaro.ikeda.g → nobody
Cahange to system app from Comment 22.
Component: Gaia::Gallery → Gaia::System
Even by applying attachment 826116 [details] [diff] [review], Gallery app sometimes draw thumbnail almost all black. But the Gallery app draw like it and the thumbnail is not all black.
Sotaro has already clarified that he was able to reproduce this on Hamachi. The reporter tested this on Helix as well. That concludes this is not device specific.
Keywords: qawanted
We already shipped 1.1 with this bug, so I'm not sure why this still needs to block.
blocking-b2g: koi+ → koi?
Minus for 1.2, please renom if needed.

The case is not strong enough to retain in 1.2. 1.1 shipped with this.
blocking-b2g: koi? → -

Comment 30

4 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #17)
> on b2g v1.2 hamachi, the problem seems to happen to almost all application.
> Just Gallery app is easier to reproduce it.
I think video app is the same as Gallery on v1.2.

Comment 31

4 years ago
One possible reason is 

open some apps at background ,then long press home button.
If the system free memory was low enough to trigger low memory killer of kernel,
then the low memory killer would kill some background apps.
And you would find the cards of apps killed were black.

I can reproduce this with almost 100% possibilities.
(In reply to ying.xu from comment #31)
> One possible reason is 
> 
> open some apps at background ,then long press home button.
> If the system free memory was low enough to trigger low memory killer of
> kernel,
> then the low memory killer would kill some background apps.
> And you would find the cards of apps killed were black.
> 
> I can reproduce this with almost 100% possibilities.

Symptom is same but cause of reason is different than the thing discussed in this bug. It should be a different bug and is already present. It is Bug 935750. The black card by app kill should be discussed there.
As of bug 1107139 landing in v2.2, if we have no screenshot (for whatever reason) for an app, we show the identification overlay instead. But even before that, I have not seen this reproduce on 2.*
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.