DNS cache is only cleared on browser restart

RESOLVED DUPLICATE of bug 151929

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 151929
4 years ago
4 years ago

People

(Reporter: rowan, Unassigned)

Tracking

23 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

1. Configure an A record with a low TTL say 60 seconds
2. Visit the url
3. Change the A record to point to another IP
4. Wait longer than the TTL and refresh the page



Actual results:

Firefox/Seamonkey queries the site on the original IP address.
Closing and reopening the browser resolve the issue. Tested in Firefox 23.0.1 and Seamonkey 2.20


Expected results:

Firefox/Seamonkey should query the new IP address.
you can workaround with a ctrl-shift-reload
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 151929
You need to log in before you can comment on or make changes to this bug.