"Self-Destructing Cookies" addon stops working

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/c8c9bd74cc40
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130819030205

Steps To Reproduce:
1. Install https://addons.mozilla.org/en-us/firefox/addon/self-destructing-cookies/
2. Turn on Add-on Bar(Ctrl+/)

Actual Results:
Tool button is not displayed in Add-on bar. 

Expected Results:
Tool button should be displayed in Add-on Bar

Regression window(fx-team)
Good:
http://hg.mozilla.org/integration/fx-team/rev/ae177d0849f5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130816133219
Bad:
http://hg.mozilla.org/integration/fx-team/rev/3fcd3420e28d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130816135818
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=ae177d0849f5&tochange=3fcd3420e28d

Regressed by:
3fcd3420e28d	Wes Kocher — Bug 906173 - Uplift addon-sdk to Firefox r=me
(Reporter)

Updated

5 years ago
tracking-firefox26: --- → ?
Component: General → Extension Compatibility
(Reporter)

Updated

5 years ago
OS: Windows 7 → All

Comment 1

5 years ago
SDC isn't working at all so it's more than the button not appearing.

Comment 2

5 years ago
I don't think this is an SDC specific issue. Look at

https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-linux64/1376920818/mozilla-inbound_ubuntu64_vm_test-jetpack-bm53-tests1-linux-build848.txt.gz

you'll find lots of `reference to undefined property value[("!" + name)]' in the test suite. Something in the add-on SDK broke.

Updated

5 years ago
Component: Extension Compatibility → General
Product: Firefox → Add-on SDK
Version: 26 Branch → unspecified
Aside from test fixes the only major piece of work in this uplift was the UX branch. Erik, Matteo, do you know what might be going on here?
Flags: needinfo?(zer0)
Flags: needinfo?(evold)
After installing the addon, I don't see the icon in the addon bar, but I also don't see any errors logged to the error console...

Comment 5

5 years ago
The error seems to be in the simple-prefs module. It returns undefined for all preferences.
Bug 717062 sounds like the culprit, then.
Blocks: 717062
No longer blocks: 906173
Erik, can you verify that bug 717062 caused this and if so back it out until a solution can be found?
Flags: needinfo?(zer0)
(In reply to Dave Townsend (:Mossop) from comment #7)
> Erik, can you verify that bug 717062 caused this and if so back it out until
> a solution can be found?

Ah damn.

My bad guys I should have seen this, https://github.com/mozilla/addon-sdk/pull/1156/files#r5859213

I'll revert the change and get it fixed.

Thanks for the quick bug report Alice and Ove!

Sorry for the trouble :(
Flags: needinfo?(evold)
I've reverted the changes in bug 717062 with https://github.com/mozilla/addon-sdk/commit/3784678ed07b074295bacd7d67ca259b043c0b8c

We should uplift this commit asap.
Assignee: nobody → evold
I pushed an uplift to fx-team in https://hg.mozilla.org/integration/fx-team/rev/a5d574cfbeac and it should merge over to mozilla-central sometime tonight or tomorrow, and make its way into tomorrow night's Nightly build.
Assignee: evold → nobody
(Reporter)

Comment 11

5 years ago
landed in http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=a5d574cfbeac

Works for me in latest Nightly.
http://hg.mozilla.org/mozilla-central/rev/14b1e8c2957e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130826074752
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
tracking-firefox26: ? → ---
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.