Closed Bug 906688 Opened 6 years ago Closed 6 years ago

[tracking] Desktop, mobile: remove Google Reader from region.properties as feed handler

Categories

(Mozilla Localizations :: Other, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: flod, Assigned: flod)

References

Details

Google Reader was removed for en-US in bug 851010. Some locales already removed it from their own repository, but the majority still has Google Reader as default feed handler.

http://mxr.mozilla.org/l10n-mozilla-beta/search?string=types\..\.title%3DGoogle&regexp=1&find=browser&findi=&filter=^[^\0]*%24&hitlimit=&tree=l10n-mozilla-beta

Locales should be able to remove the feed handler from region.properties, but they must provide at least one alternative.

en-US currently uses Yahoo! as the only protocol handler for feeds. Other possible alternatives include Bloglines or Netvibes.

browser.contentHandlers.types.0.title=My Yahoo!
browser.contentHandlers.types.0.uri=http://add.my.yahoo.com/rss?url=%s

As suggested in bug 851010 comment 7, this tracking bug could be use a reference for the commit message and later, if necessary, used as a real tracking bug if we need to work on some repositories.
OS: Mac OS X → All
Hardware: x86 → All
Duplicate of this bug: 899058
(In reply to Peter Pin-Guang Chen [:petercpg] (MozTW.org) from comment #9)
> Done for zh-TW
> http://hg.mozilla.org/l10n-central/zh-TW/rev/c7cfb8d47510
> http://hg.mozilla.org/releases/l10n/mozilla-aurora/zh-TW/rev/0da99a9133d9

Peter, please file a bug on the changes you did. This bug is only granting a rubberstamp for the removal of google, not for adding a host of other services.
(In reply to Axel Hecht [:Pike] from comment #10)
> (In reply to Peter Pin-Guang Chen [:petercpg] (MozTW.org) from comment #9)
> > Done for zh-TW
> > http://hg.mozilla.org/l10n-central/zh-TW/rev/c7cfb8d47510
> > http://hg.mozilla.org/releases/l10n/mozilla-aurora/zh-TW/rev/0da99a9133d9
> 
> Peter, please file a bug on the changes you did. This bug is only granting a
> rubberstamp for the removal of google, not for adding a host of other
> services.

ok, just backed out from all repos.
Removed for Romansh (rm)
http://hg.mozilla.org/releases/l10n/mozilla-beta/rm/rev/9933f35ba0ff
I will land this on Aurora in the next days
As my opinion, we should have someone from Mozilla to contact international service providers, rather than have each local communities do the same things. 

Filed bug 927299 for that.
Sorry for replying wrong bug above Q_Q
Component: Registration & Management → Other
Assignee: registration → nobody
Found out a few more locales still shipping Google Reader (script was fooled by the name). CCing localizers involved too, and marking this bug as fixed.

et (mobile)
http://hg.mozilla.org/releases/l10n/mozilla-aurora/et/rev/0c04909ee45b
http://hg.mozilla.org/l10n-central/et/rev/b36083a1af91

ko (desktop)
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ko/rev/acd4f8a2327b
http://hg.mozilla.org/l10n-central/ko/rev/cc950ced9b62

zh-CN (desktop)
http://hg.mozilla.org/releases/l10n/mozilla-aurora/zh-CN/rev/e63c26eec796
http://hg.mozilla.org/l10n-central/zh-CN/rev/e63c26eec796
Assignee: nobody → francesco.lodolo
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Summary: [tracking] Remove Google Reader from region.properties as feed handler → [tracking] Desktop, mobile: remove Google Reader from region.properties as feed handler
You need to log in before you can comment on or make changes to this bug.