If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

margin/vertical padding doesn't work for table cells

VERIFIED DUPLICATE of bug 2886

Status

()

Core
Layout: Tables
P3
normal
VERIFIED DUPLICATE of bug 2886
19 years ago
18 years ago

People

(Reporter: Klaus Malorny, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Vertical padding via CSS doesn't work correctly in table cells. Instead of
using the correct values, it seems that the top and bottom padding is equal to
(top + bottom) / 2. The 'margin' CSS properties don't seem to work at all. I
can set the values to anything, but the size of the cell doesn't change.

This HTML file shows the padding bug:

---8<---
<html>
<head>
<style>

.title
{ background: #f0f0f0;
  padding-top: 80px;
  padding-bottom: 20px;
}

</style>
</head>
<body>

<table>
<tr><td class=title><span style="background: #FFFF00">this is a sample

text</span></td></tr></table>
</body>
</html>
---8<---

Using any 'margin' properties (both horizontal and vertical) in the .title
style sheet doesn't change the size of the cell.


Regards

Klaus Malorny
(Reporter)

Comment 1

19 years ago
I forgot: Tested against M7.

Klaus Malorny

Updated

19 years ago
Assignee: rickg → peterl

Comment 2

19 years ago
Peter -- please take a look. It may be Chris's bug, but it also involves style.

Updated

19 years ago
Assignee: peterl → karnaze
Component: Layout → HTMLTables

Comment 3

19 years ago
Margins are not supposed to apply to internal table components (there are other
properties to control spacing there).

The padding is a table layout issue.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 2886 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 5

18 years ago
Agreed. This is a duplicate of 2886.
You need to log in before you can comment on or make changes to this bug.