If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

Firefox OS
Gaia::Keyboard
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Hans Liss, Assigned: Hans Liss)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

4 years ago
Created attachment 792285 [details]
Example of sv_SE keyboard layout in emulator

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/28.0.1500.71 Chrome/28.0.1500.71 Safari/537.36

Steps to reproduce:

In Settings | Keyboard, choose "Other Latin scripts". Touch a textbox to get the on-screen virtual keyboard to appear, and then use the globe icon to scroll through the keyboard layout. 


Actual results:

The best QWERTY keyboard layout matching a normal Swedish layout is the "nb" (Norwegian Bokmal) layout, but it uses the wrong national characters.


Expected results:

One of the layouts should be similar to the "nb" layout, but have the Swedish "å", "ä" and "ö" keys, with "å" to the right of "p", and "ö" followed by "ä" to the right of "l".
(Assignee)

Comment 1

4 years ago
Created attachment 792364 [details] [diff] [review]
Patch - new keyboard layout sv_SE
Attachment #792364 - Flags: review?
(Assignee)

Comment 2

4 years ago
Created attachment 794303 [details] [review]
Pull request link to GitHub
Attachment #792364 - Attachment is obsolete: true
Attachment #792364 - Flags: review?
(Assignee)

Updated

4 years ago
Attachment #794303 - Flags: review?(rlu)
Thanks for your contribution on this.

I will get to review your patch later. 
Please stay tuned. :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 794303 [details] [review]
Pull request link to GitHub

Hi Hans,

Looks good, it works even with the new IME framework.
Great work!

Before merging your patch, could you please please squash your commits into a single commit, with the following command?
 > git rebase -i master

If you need any help, please just let me know and I'll do it for you.
Attachment #794303 - Flags: review?(rlu) → review+
Assignee: nobody → mozilla
Status: NEW → ASSIGNED
(Assignee)

Comment 5

4 years ago
> Looks good, it works even with the new IME framework.
> Great work!

Nice! Thanks for your help!

> Before merging your patch, could you please please squash your commits into
> a single commit, with the following command?
>  > git rebase -i master
> 
> If you need any help, please just let me know and I'll do it for you.

I think I managed to figure it out. Please verify that I achieved what you requested.
Yes, thanks for taking care of this.

Landed to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/f94d4a9b56e8cc253089fe5ff680eb3cde303243

:)
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
backed out as part of the general backout of the 3rd party keyboard customizations (https://github.com/mozilla-b2g/gaia/commit/42aa1e2ccd22e464bffe6b22ee1182cece5dc2dc) Due to b2g-desktop failures (fail to start) https://travis-ci.org/mozilla-b2g/gaia/builds/10571231#L129.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Re-landed to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/20492078ec26b33ec64bb3789014eae86f438b9b
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.