[B2G][Homescreen]Adding webpage icon to Homescreen causes device to freeze

RESOLVED DUPLICATE of bug 903969

Status

Firefox OS
Gaia::Homescreen
RESOLVED DUPLICATE of bug 903969
5 years ago
5 years ago

People

(Reporter: Montoya Clemmons (MClemmons), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 792313 [details]
Logcat of Repro Steps

Description:
Web page icon is allowed to be added to Homescreen but further attempts to scroll, swipe, or tap causes the device to be non-responsive for long period of time

Repro Steps:
1) Updated Unagi to Build ID: 20130819040203
2) Tap Settings App
3) Scroll to Help
4) Tap Help
5) Tap User Guide
6) Tap the star icon lower right corner of screen
7) Tap Add to home screen
8) Tap Add to Home Screen 
9) Tap Home 
10) Long tap Firefox OS | Firefox help
11) Tap red x to upper left of Firefox OS | Firefox help

Actual:
device freezes for several minutes (user cannot swipe, scroll, tap, or long press to restart or turn off phone) 

Expected:
option appears on screen to delete Firefox OS | Firefox help

Environmental Variables
Build ID: 20130819040203
Gecko: http://hg.mozilla.org/mozilla-central/rev/c8c9bd74cc40
Gaia: f6de05c135913f2cb790759335875bb1b3c4f9bb
Platform Version: 26.0a1

Notes:
Repro frequency: 5 out of 5 times
See attached: logcat attached
Optional extra notes: Only user options are:
1. open back of phone, take out battery and place battery back in to reset the phone
2. wait 3-5 minutes for expected result to appear on screen - even when this occurs, the remove button does not respond naturally. Tap remove and device is stuck on page for several minutes before icon is removed from homescreen 
3. does not reproduce on Leo 1.1 Com
Same genlock error seen in bug 903969.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 903969
You need to log in before you can comment on or make changes to this bug.