Some of the downloadmgr tests fail on Win64

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
RESOLVED WORKSFORME
5 years ago
a year ago

People

(Reporter: Away for a while, Assigned: Paolo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
<https://tbpl.mozilla.org/?tree=Date&rev=c8c9bd74cc40>

Paolo, can you please take a look at this?  Thanks!
(Assignee)

Comment 1

5 years ago
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #0)
> <https://tbpl.mozilla.org/?tree=Date&rev=c8c9bd74cc40>

Which are the tests that you think are failing on 64-bit specifically? I see
some failures that look like instances of bug 901017, but can't figure out if
they are more consistent on 64-bit. A comparison of 32 and 64 bit test logs
of the same source revision might be helpful.
Hardware: x86 → x86_64
(Reporter)

Comment 2

5 years ago
(In reply to Paolo Amadini [:paolo] from comment #1)
> (In reply to :Ehsan Akhgari (needinfo? me!) from comment #0)
> > <https://tbpl.mozilla.org/?tree=Date&rev=c8c9bd74cc40>
> 
> Which are the tests that you think are failing on 64-bit specifically? I see
> some failures that look like instances of bug 901017, but can't figure out if
> they are more consistent on 64-bit. A comparison of 32 and 64 bit test logs
> of the same source revision might be helpful.

All of the downloadmgr tests that are failing on Date?  The Date branch is basically a Win64 build of mozilla-inbound, and these failures are not intermittent there.  We need to fix them so that we can turn on Win64 builds on inbound/central/etc.
(Assignee)

Comment 3

4 years ago
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #2)
> these failures are not intermittent there

Except maybe one case, the other symptoms of the failing tests are the same as the intermittent failures we have on mozilla.central and that should be fixed by the two bugs I linked as dependencies. The fact they happen systematically may be caused by different performance or scheduling characteristics of the test machines.

Let's see what the situation is after the intermittent failures have been fixed!
Depends on: 915214, 920017
(Assignee)

Comment 4

4 years ago
Can you test again with the latest mozilla-central revision and see if the issues have been resolved?
Flags: needinfo?(ehsan)
(Reporter)

Comment 5

4 years ago
(In reply to :Paolo Amadini from comment #4)
> Can you test again with the latest mozilla-central revision and see if the
> issues have been resolved?

Not sure how the Date branch is managed these days.  Vlad?
Flags: needinfo?(ehsan) → needinfo?(vladimir)
Just manual merges/pushes to it for sanity.
Flags: needinfo?(vladimir)
(Reporter)

Comment 7

4 years ago
(In reply to comment #6)
> Just manual merges/pushes to it for sanity.

So should Paolo try merging m-c into Date and push it there?
(Assignee)

Comment 8

4 years ago
(In reply to Vladimir Vukicevic [:vlad] [:vladv] from comment #6)
> Just manual merges/pushes to it for sanity.

So, there is no hurry to test this issue in particular. We can leave this bug open, and when someone executes the next merge for other reasons, we can verify where we are with regard to the tests mentioned here.
None of these tests are disabled on Win64 today (skip-if processor == "x86_64"), so presumably these tests are no longer failing on Win64.

searchfox.org/mozilla-central/search?q=skip-if.*processor&regexp=true
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.