Closed Bug 906867 Opened 6 years ago Closed 6 years ago

Can't build with --disable-webspeech; build fails out with "dom/ipc/PContent.ipdl:20: error: can't locate include file `PSpeechSynthesis.ipdl'"

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26

People

(Reporter: dholbert, Assigned: eeejay)

References

Details

Attachments

(1 file)

When I try add this to my debug build mozconfig...
  ac_add_options --disable-webspeech
...my build fails, with this output:
{
/mozilla/dom/ipc/PContent.ipdl:20: error: can't locate include file `PSpeechSynthesis.ipdl'
Traceback (most recent call last):
  File "/mozilla/config/pythonpath.py", line 56, in <module>
    main(sys.argv[1:])
  File "/mozilla/config/pythonpath.py", line 48, in main
    execfile(script, frozenglobals)
  File "/mozilla/ipc/ipdl/ipdl.py", line 127, in <module>
    if not ipdl.typecheck(ast):
  File "/mozilla/ipc/ipdl/ipdl/__init__.py", line 35, in typecheck
    return TypeCheck().check(ast, errout)
  File "/mozilla/ipc/ipdl/ipdl/type.py", line 596, in check
    if not runpass(GatherDecls(builtinUsing, self.errors)):
  File "/mozilla/ipc/ipdl/ipdl/type.py", line 586, in runpass
    tu.accept(tcheckpass)
  File "/mozilla/ipc/ipdl/ipdl/ast.py", line 135, in accept
    return visit(self)
  File "/mozilla/ipc/ipdl/ipdl/type.py", line 694, in visitTranslationUnit
    pinc.accept(self)
  File "/mozilla/ipc/ipdl/ipdl/ast.py", line 135, in accept
    return visit(self)
  File "/mozilla/ipc/ipdl/ipdl/type.py", line 758, in visitInclude
    inc.tu.accept(self)
  File "/mozilla/ipc/ipdl/ipdl/ast.py", line 135, in accept
    return visit(self)
  File "/mozilla/ipc/ipdl/ipdl/type.py", line 711, in visitTranslationUnit
    if inc.tu.filetype == 'header':
}

(This is a clobber build.)
Looks like this happened in the transition to moz.build. Unless you beat me to it, I'll have a patch ready soon.
Thanks!
Assignee: nobody → eitan
Attachment #792468 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/b1b090ac0344
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Duplicate of this bug: 890471
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.