È is listed as ? in marketplace

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: krupa.mozbugs, Unassigned)

Tracking

Points:
---

Details

(Reporter)

Description

5 years ago
steps to reproduce:
1. Load https://marketplace.firefox.com/app/buscape/
2. Check the app name @ http://www.buscape.com.br/manifest.webapp


observed behavior:
 È in the app name is listed as ? in marketplace
%% curl 'http://www.buscape.com.br/manifest.webapp' -I
HTTP/1.1 200 OK
Server: Apache-Coyote/1.1
Connection: max-age=25920
Content-Type: application/x-web-app-manifest+json;charset=ISO-8859-1
Content-Language: en-US
Content-Length: 694
Date: Mon, 19 Aug 2013 22:25:31 GMT

The validator should throw a warning/error if it's not Content-Type: application/x-web-app-manifest+json;charset=UTF-8 - I thought we were presently doing this.

Comment 2

5 years ago
We don't respect the Content-Type charset. Per the manifest docs:

    The manifest must be in UTF-8 encoding in order for the app to be submitted to Firefox Marketplace.

https://developer.mozilla.org/en-US/docs/Web/Apps/Manifest#Serving_manifests
https://github.com/mozilla/zamboni/blob/master/mkt/developers/tasks.py#L515

If the manifest gets properly decoded as UTF-8, but it's actually *not* UTF-8, then there's nothing we can do about that. RESOLVED DONTDOTHATTHEN
It looks like they are serving the manifest with UTF-8 now, but they didn't reencode the document and now it's broken the other way, eg:

>     "name": "Buscap� Company",

Krupa - did you tell them about the UTF-8 change?
(Reporter)

Comment 4

5 years ago
(In reply to Wil Clouser [:clouserw] from comment #3)
> It looks like they are serving the manifest with UTF-8 now, but they didn't
> reencode the document and now it's broken the other way, eg:
> 
> >     "name": "Buscap� Company",
> 
> Krupa - did you tell them about the UTF-8 change?

done
The developer's manifest is still encoded as ISO-8559-1 - nothing we can do until the developer makes this UTF-8.
There isn't anything we can do here.  If the name doesn't appear correctly it should be caught by a reviewer when it is in the queue.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.