mozilla gets binary data instead of html from http://www.zantetsuken.com/board/ohrmsgb/

RESOLVED DUPLICATE of bug 86235

Status

()

Core
Networking: HTTP
P2
major
RESOLVED DUPLICATE of bug 86235
17 years ago
17 years ago

People

(Reporter: James Paige, Assigned: neeti)

Tracking

Trunk
mozilla0.9.4
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
Build 2001071104 and build 2001071304 on Windows 95

visit http://www.zantetsuken.com/board/ohrmsgb/ which is a message board. The
main page loads okay.

Try to read any post. instead of seeing the post as you do in NS 4.x, IE, and
Lynx, you see a blank page.

I did "file->save as" from Mozilla and saved the blank page to disk, and when i
check it with a hex editor, it was just a glob of binary data.

This happens fo every single post on the board.

I will attach output from one of the posts as an example:
http://www.zantetsuken.com/cgi-bin/cgiwrap/zantetsuken/rpgboard/viewer.cgi/ohrmsgb/3B4F15030000069A.html
(Reporter)

Comment 1

17 years ago
Created attachment 42186 [details]
the actual source of a post (pulled with graburl.exe)
(Reporter)

Comment 2

17 years ago
Created attachment 42193 [details]
what mozilla gets (from file->save)
(Reporter)

Comment 3

17 years ago
Created attachment 42194 [details]
a post's headers (pulled with graburl.exe)

Comment 4

17 years ago
If I 'D'ownload a link to a post in Lynx, it tells me it's saving a file of type
application/x-compress.

In moz (Linux 2001071306), if I remove "compress," from Prefs > Debug >
Networking > Accept-Encoding, the page renders properly.

Why aren't we picking up the content-encoding properly?

Comment 5

17 years ago
On today's branch build i only get blank pages on those .html postings
Weird
I am marking this one as NEW for now
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

17 years ago
after reading bug 86235 , I suspect this might be a duplicate of it, but not
with enough confidence to mark it as such right away. ccing pchen, since bug
86235 is his

Comment 7

17 years ago

*** This bug has been marked as a duplicate of 86235 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Priority: -- → P2
Resolution: --- → DUPLICATE
Target Milestone: --- → mozilla0.9.4
You need to log in before you can comment on or make changes to this bug.