xml examples not loading (work in IE5; use XSL)

VERIFIED INVALID

Status

SeaMonkey
General
P3
critical
VERIFIED INVALID
19 years ago
13 years ago

People

(Reporter: wmpresby, Assigned: don)

Tracking

Trunk
PowerPC
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
The browser will not show any of the xml examples on this page, instead returning
an "xml parsing error" and showing the first (commented) line of the code in the
browser window. These examples are loading and runnning fine in IE 5 on my
NT machine.

Comment 1

19 years ago
*** Bug 9071 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Summary: xml examples not loading (work in IE5; use XSL)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 2

19 years ago
Try getting removing the first return character at the beginning of the
document.

You will get a little further. Your pages will not work because Mozilla does not
support XSL,

   http://www.mozilla.org/newlayout/faq.html#cssnotxsl

Marking INVALID.

Comment 3

19 years ago
Just to elaborate (for wmpresby@colby.edu benefit): it is a bug in
Microsoft's implementation of XML to *not* throw an error if '<?xml ...' are
not the first characters in an XML document (you may omit '<?xml ...' but it
you include it, then they must be the first characters).
http://www.w3.org/TR/REC-xml is clear on this point. However,
one might reasonably ask "Why is it important to be strict on this
point?". The answer is at http://www.w3.org/TR/REC-xml#sec-guessing, and the
reason is to allow for the auto-detection of character encoding.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
Verified Invalid
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.