zffos1.1 The lockedscreen displays the wrong content for SPN information.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: ji.chen5, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; CIBA; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; InfoPath.2; .NET4.0C; .NET4.0E; .NET CLR 3.5.30729; TCO_20130820144108)

Steps to reproduce:

Lock the Screen.


Actual results:

It displays "TEM" and "Movistar" in "SPAN" and "PLMN"areas.


Expected results:

It should display "Movistar" and "Movistar" in two areas.
(Reporter)

Updated

5 years ago
Blocks: 899451
Do I need specific SIM card to reproduce it? Or is there more detailed step. I just locked my screen but don't know where to see this information.
Flags: needinfo?(ji.chen5)
Chen, could you also attache a screenshot. Thank you!
(Reporter)

Comment 3

5 years ago
Created attachment 793243 [details]
I have indicate the place where should display "Movistar|Movistar" not "TEM|Movistar".
Flags: needinfo?(ji.chen5)
(Reporter)

Comment 4

5 years ago
I have pointed out the place where should display "Movistar|Movistar" not "TEM|Movistar." Please check the picture in attachment.
(Reporter)

Comment 5

5 years ago
Created attachment 793251 [details]
The wrong content have been pointed out where should display "Movistar|Movistar" not "TEM|Movistar".
Attachment #793243 - Attachment is obsolete: true

Comment 6

5 years ago
SPN is read from SIM card, PLMN is read from network. PLMN has short and long name.

In this issue, the SPN we read is: MOVISTAR, the PLMN short/long name we read are: TEM and MOVISTAR.

So we think, in the lock screen, you only show PLMN short and long name, as requirement, you should show SPN and PLMN long name
Hi Baisheng,

Since Gecko/Gaia in FFOS is general solution, we suggest not changing the logic in gecko/gaia. We suggest asking commercial RIL to copy the MOVISTAR to short name to resolve this case.

Ivan Tsay
Flags: needinfo?(zhang.baisheng)

Comment 8

5 years ago
Hi Ivan,

  On Android and Windows mobile, they are using long name for this.
If you insist, could you tell us where to set? I think zte can maintain this small change.
Flags: needinfo?(zhang.baisheng)

Comment 9

5 years ago
Long/short name are restored in modem side, please check if protocol side can revise thier ROM table for long/short name.

Thanks!
sku
(In reply to zhangbaisheng from comment #8)
> Hi Ivan,
> 
>   On Android and Windows mobile, they are using long name for this.
> If you insist, could you tell us where to set? I think zte can maintain this
> small change.

Hi Baisheng,

Thank you for the comment, as for tight schedule by now, probably change it in ZTE side will be faster solution. But I will bring back this comments in Mozilla for further discussion.

Comment 11

5 years ago
(In reply to shawn ku [:sku] from comment #9)
> Long/short name are restored in modem side, please check if protocol side
> can revise thier ROM table for long/short name.

Thanks!
sku

Hi shawn,
 I know where to change it in the RIL, I mean where to change in the gaia or gecko layer? Because I'm afraid that if we change in the RIL, maybe some third party app will show the wrong info then.

Comment 12

5 years ago
Hi:
 I am not sure if I got your point.

you can refer to below two places to check where is the location you need.

gaia part: userFacingInfo@gaia/shared/js/mobile_operator.js
gecko part: _processOperator@dom/system/gonk/ril_worker.js

Besides, change in gaia part might impact some apps behavior that cause un-synced with gecko.
change in gecko will impact all apps behavior as changed in modem side.

Thanks!
sku

Comment 13

5 years ago
In my comments "RIL" means Modem, so you are right, we will check, thank you
Hi Baisheng,

Please close this bug when it is fixed from your side. Thank you!
Flags: needinfo?(zhang.baisheng)
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.