[Browser] On unstable connections internal state can become wrong

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
8 months ago

People

(Reporter: janjongboom, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: sprintready)

This is on 1.1 hamachi partner release from the beginning of August.

First of all, it's hard to make a reproducable scenario here. This weekend I was on a festival with very very unstable internet and the following things happened.

* Page starts loading, takes ages (also the user has no clue because bug 853457 is not uplifted), then stops (progress disappears) but nothing is shown to the user
* After this the browser thinks it navigated away, so when tapping the URL bar the new URL is there, but also: screenshots/favicon/title for the page are replaced with the old page in history and top sites
* Browser behavior breaks at one point. F.e. I couldn't log in into mobile banking because at one point the browser just stopped working. Had to close tab and re-open. Think it's related because all is fine on normal connection.
Whiteboard: sprintready

Comment 1

5 years ago
A Pivotal Tracker story has been created for this Bug: http://www.pivotaltracker.com/story/show/55926808

Comment 2

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.