Firefox 23.0.1 not supported by Mozilla Persona login

RESOLVED WONTFIX

Status

Mozilla QA
MozTrap
--
major
RESOLVED WONTFIX
5 years ago
10 months ago

People

(Reporter: Eric Moore, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I went to login to https://moztrap.mozilla.org/runtests/environment/1974/ (Thunderbird testing) and got a "We are sorry, but currently your browser is not supported. <Firefox logo> Persona works with Firefox and other modern browsers" error message. 

I'm using Firefox 23.0.1 under Windows 7 x64, there is a cookie exception for mozilla.org (cookies are disabled), and javascript is enabled. I also tried with Firefox in safe mode to verify it wasn't due to an add-on.

I also tried with https://mozillians.org/en-US/ to verify it wasn't a web site specific bug. It used to work with older versions of Firefox. It works with Opera 12.15 and IE 10. 

I assume this isn't a duplicate of 899112 since I explicitly enabled cookies for Mozilla.org (the web site I was trying to use Persona to login into) and I got a error message about Firefox not being a modern browser rather than silently failing.
(Reporter)

Comment 1

5 years ago
Same problem using the current 24.0 beta.

Comment 2

5 years ago
Persona bug? Or moztrap?

I haven't tried 23beta or 24beta. But I've not seen the problem when using recent trunk.
Severity: normal → major
Component: General → MozTrap
Product: Firefox → Mozilla QA
Version: 23 Branch → unspecified
(Reporter)

Comment 3

5 years ago
The latest 24.0 beta has the same problem if I use the same profile. If I create a new profile with all default values the 24.0 beta has no problem. So, it appears this problem depends upon the profiles settings. 

I use the memory cache and disable the disk cache, cookies, history, and offline storage.

browser.cache.disk.enable , browser.cache.disk.smart_size.enabled, browser.cache.offline.enable, dom.storage.enabled, and places.history.enabled are false. browser.cache.disk.capacity and browser.cache.disk.smart_size_cached_value are zero.
browser.cache.disk.parent directory doesn't exist.
(Reporter)

Comment 4

5 years ago
Created attachment 792898 [details]
text from help -> troubleshooting information

Comment 5

5 years ago
Roping in the Persona development folks... Lloyd, Ben, any thoughts on this? Feels to me like some sort of problem with the Persona javascript, or maybe the IdP? Sounds like it's too early in the UX to be IdP-related...
Flags: needinfo?(lhilaiel)
I expect this was related to disabled 3rd party cookies.

Can you still reproduce (I know, it's been a long time) - if so, can you confirm that the issue is cookie settings?
Flags: needinfo?(lhilaiel)

Updated

4 years ago
Flags: needinfo?(tanstaafl)
(Reporter)

Comment 7

4 years ago
Sorry about the delay.

I get the same "We are sorry, but currently your browser is not supported. <Firefox logo> Persona works with Firefox and other modern browsers" error message using Firefox 26.0. I clicked on accept cookies from sites but set third party cookies to never. Same symptoms. I then set third party cookies to always.  Clicking on the signin button did nothing (appears to be some retry limit) so I created a new tab and tried again. I got the same error message. 

I restarted Firefox and tried again (accept cookies still enabled and third party cookies still set to always). Same symptom. I restarted Firefox in safe mode and tried again. Same symptoms. 

I confirmed it still works with Opera 12.15.
Flags: needinfo?(tanstaafl)

Comment 8

4 years ago
suspect we should no longer care about this. 
wontfix?
Flags: needinfo?(cdawson)
(Reporter)

Comment 9

4 years ago
The problem still occurs with Firefox 30.0 . I have a exception to allow cookies for mozilla.org and verified that I have cookies for both bugzilla.mozilla.org and moztrap.mozilla.org. about:support lists the correct application name, version and user agent. 

Why do you suggest that we should not care about this? Please be explicit. Its pretty bad if the persona login can't even recognize that I'm using Firefox because of some hidden dependency. It should at least provide the user some clue that they can use to help troubleshoot the problem.

Comment 10

4 years ago
My comments were based on this last reported not working for rather old verosions of Firefox. If it fails for a current version that's a different picture. 

What cookie settings are required to make it fail?
I have not been able to reproduce this.  Though I think the persona version in MozTrap is a little old.  Perhaps it would work better with an updated package.

Peter: how about this as a candidate to work on, too, when you have some cycles.
Flags: needinfo?(cdawson)
Eric, 
Do you have the "honeybadger" plugin? I can't remember what it's called but I remember hearing people using this and it made some Persona sign ins stop working. There were some bugs filed on the plugin, not on Persona.
Flags: needinfo?(tanstaafl)
And by "honeybadger" I meant https://www.eff.org/privacybadger oops. 
Do you have that installed?
(Reporter)

Comment 14

4 years ago
I originally didn't use the PrivacyBadger plug-in (see the attachment with information from "help -> troubleshooting information") when I reported the bug. I do now (I replaced Ghostery with it)  However, the problem also occurs with Firefox 30.1 while running in safe mode. 

I have two Firefox profiles - tanstaafl and netflix. netflix has hardly any customizations. tanstaafl is my normal profile, and has many customizations. I created the netflix profile because I couldn't stay logged into Netflix anymore when restarting, after a change on their web site. I talked with Netflix customer support numerous times trying to identify what setting (cookies, cached web content, offline web content etc.) it depended upon and asked for help in the Mozillazine forums. No luck. I mention it (its a unrelated problem) only because this isn't the first time this type of thing has happened to me.

I'm skeptical that this bug has anything do with cookies or add-ons since it occurs in safe mode using my tanstaafl profile, and does not occur in normal mode with my netflix profile. Both have a exception to allow cookies for mozilla.org.
Flags: needinfo?(tanstaafl)
So you're still not able to sign in with either of these profiles?
That's not good. 

It's hard to know but I did notice that we're using an older version of django-browserid which I could upgrade but I'm not sure it'll make a difference because I can't reproduce the problem of logging in.
(Reporter)

Comment 16

4 years ago
It fails (your browser is not supported...) using the tanstaafl profile, even in safe mode. I can login using the netflix profile. Is there a publicly available URL for testing persona that provides debugging information that I could try?
Dan, 
Eric here is really struggling to sign in to Moztrap using Persona. 
I can't reproduce it. He suspects with a certain profile (even in modern version of Firefox) he can't sign in to any Persona protected site. 
Are there any good tools for debugging these things? Like some soup-ed up debugger Persona sign in test page?
Flags: needinfo?(dan.callahan)
Oops, missed this needinfo. Clearing it.

The "unsupported browser" screen shows if we can't use localStorage, can't set cookies, or if your browser doesn't support JSON.

When I've seen this happen on modern Firefox, it's almost always due to add-ons, restrictive third party cookie settings, or a corrupt localStorage database. In the latter case, you should see errors in the browser console (Menu -> Developer -> Browser Console).
Flags: needinfo?(dan.callahan)

Comment 19

3 years ago
Eric, are you still seeing this?

Using 2014-12-18 nightly I'm getting this just now https://login.persona.org/unsupported_dialog trying to login to https://developer.mozilla.org/
Flags: needinfo?(tanstaafl)
(Reporter)

Comment 20

3 years ago
Both https://moztrap.mozilla.org/users/login/?next=/runtests/environment/1974/ and https://developer.mozilla.org/en-US/ return "We are sorry, but currently your browser is not supported" and https://mozillians.org/en-US/ doesn't do anything using Firefox 38.

"Tell me when a website asks to store data for offline use" is checked. I don't get a prompt. I see recent json files in my bookmarks backup directory in the profile. I have cookies enabled for the websites I tried to log into, though developer.mozilla.org is set to first party only.

I cleared the browser console before testing this. I noticed "TypeError: window.sessionStorage is null" and "TypeError: localStorage is null" . Perhaps the code to ask to store data for offline use doesn't play nicely with persona?
Flags: needinfo?(tanstaafl)
Mass-closing remaining MozTrap bugs as WONTFIX, due to 1) the Mozilla-hosted instance being decommissioned (see https://wiki.mozilla.org/TestEngineering/Testrail), and, for now, 2) the still-up code archived at its GitHub page: https://github.com/mozilla/moztrap (we'll decide what's next for that, in the near future).

See also the history and more-detailed discussion which led us here, at https://groups.google.com/forum/#!topic/mozilla.dev.quality/Sa75hV8Ywvk

(If you'd like, you should be able to filter these notification emails using at least the unique string of "Sa75hV8Ywvk" in the message body.

Thanks!
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.