subscribe crash (outliner selection is null) - Trunk [@ nsOutlinerSelection::SetCurrentIndex ]

VERIFIED FIXED in mozilla0.9.3

Status

SeaMonkey
MailNews: Message Display
P1
critical
VERIFIED FIXED
17 years ago
7 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash, topcrash})

Trunk
mozilla0.9.3
x86
Windows 2000
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(4 attachments)

bienvenu and I (probably stephend, too) has seen this crash.

clicking on the dot or check in the search view (for subscribe) sometimes 
crashes.

the outliner selection is null.

when we get a stack, we'll post in here.

Updated

17 years ago
Severity: normal → critical
Keywords: crash
Created attachment 42225 [details]
Stack Trace using build 2001-07-13-04 on Windows 2000.

Comment 2

17 years ago
Some reproducable steps would be useful if possible...

Comment 3

17 years ago
It's not 100% reproducible - it seemed to happen to me about 1/3 of the time
when I did the following:

1. Bring up subscribe ui.
2. use typedown to reduce the list of newsgroups to a few groups (I did vb, I
think, on the msnews server, but I also saw it on our newsserver)
3. Click on the "." to subscribe. 

Often, clicking on the "." does not set the checked mark, and I have to click on
the "." three times to get subscribed. Other times, I crash.

Comment 4

17 years ago
I tried with a slightly different stack when I did this (inspired by bienvenu's 
testcase):

1. Open subscribe window
2. Type in 'vb'
3. Drag the thumb to attempt to scroll

crash!

This is reproducable sometimes only. But it's always crashing exactly when I 
try dragging the thumb in the scrollbar.

Comment 5

17 years ago
Created attachment 42406 [details]
Stack trace from hwaara's testcase
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla0.9.3

Comment 6

17 years ago
Adding topcrash keyword and Trunk [@ nsOutlinerSelection::SetCurrentIndex ] to
summary.  This is in the Talkback topcrash reports for MozillaTrunk.  Here is
some info on the crash from Talkback:

Incident ID 32874650
Stack Signature nsOutlinerSelection::SetCurrentIndex() 4af90147
Bug ID
Trigger Time 2001-07-13 16:28:24
User Comments Linux news crasher. This time, I didn't even click the dot.
Assuming that in this subscribe window, I'm still hitting the null outliner
selection though.
Build ID 2001071308
Product ID MozillaTrunk
Platform ID LinuxIntel

Incident ID 32650128
Stack Signature nsOutlinerSelection::SetCurrentIndex c8777a43
Bug ID
Trigger Time 2001-07-08 10:09:27
User Comments selection a news group to subscribe to. The list was the result of
a search, with this being the 1st selection.
Build ID 2001070710
Product ID MozillaTrunk
Platform ID Win32

Incident ID 32521308
Stack Signature nsOutlinerSelection::SetCurrentIndex 26378e43
Bug ID
Trigger Time 2001-07-04 11:43:03
User Comments using the subscribe/unsubscribe dialogue box in the Mozilla newsreader
Build ID 2001070110
Product ID MozillaTrunk
Platform ID Win32

Incident ID 32552788
Stack Signature nsOutlinerSelection::SetCurrentIndex 5a978371
Bug ID
Trigger Time 2001-07-05 08:57:27
User Comments Moving multiple emails from inbox to folder, on imap server
Build ID 2001060713
Product ID Netscape6.10B1
Platform ID Win32

Those are just the entries that had useful steps to reproduce...and I won't
bother putting the stack in, since there are already 2 attachments.  Although
this is showing up on the topcrash report, it might be because we have been
reproducing it internally for testing, so prioritize this topcrasher
accordingly.  Thanks Stephen for pointing me to the right bug.
Keywords: topcrash
Summary: subscribe crash (outliner selection is null) → subscribe crash (outliner selection is null) - Trunk [@ nsOutlinerSelection::SetCurrentIndex ]
Created attachment 42497 [details] [diff] [review]
patch that fixes some problems
that patch does fix the crasher,  but it's good stuff anyways.

I think I've got an idea about what is causing the crasher.  additional patch 
on the way.
s/that patch does fix the crasher/that patch does not fix the crasher
the problem is that I'm storing the selection in the view.

the view in this case is implemented by nsNntpIncomingServer.

the nsNntpIncomingServer object sticks around and I don't reset the selection 
between subscribe sessions.

so, to reproduce this crasher, start up, use the search functionality of 
subscribe on a server, close subscribe, and do it again.

boom.

working on the fix now.
Created attachment 42522 [details] [diff] [review]
patch from problems and the crash

Comment 12

17 years ago
Interesting. Seth, does your latest patch fix both crashes - assuming my and
stephend's stacktraces are different crashes?
yes, it should fix both crashes.

I saw several flavors of the crash, and they were all because we were
dereferencing mOutliner, a member variable of nsOutlinerSelection.

this patch also addresses part of the problem bienvenu mentioned:

"Often, clicking on the "." does not set the checked mark, and I have to click
on the "." three times to get subscribed."

can I get some reviews?

Comment 14

17 years ago
Looks to me like good changes for safety's sake. r=hwaara

Comment 15

17 years ago
sr=bienvenu
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Jay, yes, I was testing this bug and sending in the TB reports, so you're
assumption about it being in the topcrash for that reason is correct ;-)
This is Verified FIXED on all 2001-07-19-13 builds (Mac OS 9.1, Windows 2000 and
RedHat Linux 7.1).  No more crashing!
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: stephend → search
Crash Signature: [@ nsOutlinerSelection::SetCurrentIndex ]
You need to log in before you can comment on or make changes to this bug.