table cells where width=1 do not show in m7

VERIFIED WORKSFORME

Status

()

P3
minor
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: ushackles, Assigned: karnaze)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE] elentar@pacbell.net)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Cells where width=1, which is very useful for horisontal rules etc, does not
display in mileston 7. As in all netscape navigators I've tried (nav 2 - moz,
m6) it does not show if you have got NOTHING in the cell, but will show if you
put text or something there (for example  ) however this results in a cell
quite much wider than one pixel. To fix this you can put in a <spacer type=block
width=1>, which works fine in all old navigators and mozilla except for
milestone 7. It works fine in m6 and older. Why? I've tried in both apprunner
and viewer. I'm runnning NT4 and m7 with build id 1999062113.

/Uncle Shackles
(Reporter)

Comment 1

19 years ago
Created attachment 628 [details]
Example table
(Reporter)

Comment 2

19 years ago
oops, VERTICAL ruler that is :)

Updated

19 years ago
Whiteboard: [MAKINGTEST] elentar@pacbell.net

Comment 3

19 years ago
Created attachment 768 [details]
HTML File that correctly displays 1-pixel cell

Comment 4

19 years ago
[TESTCASE]
The <spacer> tag is proprietary and not part of the W3C spec for HTML 4.0 or
lower. Because of this, I would assume that supporting it is not a required
feature for Mozilla. See attachment #767 [details] for a proper version that uses the
<div> tag instead.

This should probably be marked invalid, but I don't know the status of the
<spacer> tag support.

Comment 5

19 years ago
Err, Attachment #768 [details]. Oops!

Updated

19 years ago
Whiteboard: [MAKINGTEST] elentar@pacbell.net → [TESTCASE] elentar@pacbell.net
(Reporter)

Comment 6

19 years ago
The <spacer> tag is WIDELY supported, it's even implemented in iexplore 3! :)
It also seems to work fine in mozilla except when in a width 1 cell. Also, when
using <div> instead of <spacer> the cell wont display in communicator 4.5 ...
It's all very confusing since it this bug does not occur in mozilla m6.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M10
(Assignee)

Updated

19 years ago
Target Milestone: M10 → M11

Comment 7

19 years ago
The original "Example table" attachment, using SPACER (id=628),
displays as intended with 1999-10-12-16-M11 on Windows NT.

The <DIV>, css-based "HTML File that correctly displays 1-pixel cell"
attachment does not work as intended on Nav 4.7, nor, I suspect, any
previous Navigator, making it extremely unlikely to be adopted as a
work-around by the general run of web designers.
(Assignee)

Comment 8

19 years ago
Moving to M13.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 9

19 years ago
The 1px spacer appears to be working again.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
Using 11/16 build, verified WORKSFORME
You need to log in before you can comment on or make changes to this bug.