[MP] Defect - Downloads not working (no UI displayed), console reports "Strings is not defined" in HelperAppDialog.js

VERIFIED FIXED in Firefox 26

Status

defect
P2
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: flod, Assigned: sfoster)

Tracking

unspecified
Firefox 26
All
Windows 8
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [preview] feature=defect c=tbd u=tbd p=1)

Attachments

(2 attachments)

When I try to download something from Firefox Metro, I click on a link, I see a quick animation on the bottom blue/gray line, the navigation bar appears but nothing else. In my Downloads folder I found only .part files, this error is reported in the console:

Error: Strings is not defined
resource://app/components/HelperAppDialog.js
Line: 45

I'm currently using a localized build (2013-08-19), but I had the same problem with an en-US build.
http://mxr.mozilla.org/mozilla-central/source/browser/metro/components/HelperAppDialog.js#45

Is Strings.browser not available in components?
Whiteboard: [preview]
Summary: Downloads not working (no UI displayed), console reports "Strings is not defined" in HelperAppDialog.js → [MP] Defect - Downloads not working (no UI displayed), console reports "Strings is not defined" in HelperAppDialog.js
Whiteboard: [preview] → [preview] feature=defect c=tbd u=tbd p=0
I've got this covered in a patch on bug 893091. I can break it out associate it with this ticket though.
QA Contact: sfoster
See Also: → 893091
There's no Strings global in this component, this patch create a localized message bundle and get the downloadsUnknownSize from it (same pattern as used elsewhere in the file)
Assignee: nobody → sfoster
Status: NEW → ASSIGNED
Attachment #793014 - Flags: review?(ally)
Blocks: metrov1it13
No longer blocks: metrov1backlog
Priority: -- → P2
QA Contact: sfoster → jbecerra
Whiteboard: [preview] feature=defect c=tbd u=tbd p=0 → [preview] feature=defect c=tbd u=tbd p=1
Comment on attachment 793014 [details] [diff] [review]
Fix localized string access for download size

Review of attachment 793014 [details] [diff] [review]:
-----------------------------------------------------------------

I'm not sure you really need me for this. :) ship it
Attachment #793014 - Flags: review?(ally) → review+
https://hg.mozilla.org/mozilla-central/rev/639899ea2f57
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130827030201

WFM
Tested on both Windows 8 32bit and 64bit using latest Nightly for iteration #13 and following the indications from comment 0. The download worked as expected (with UI shown), no .part files and no error reported in the console.
Status: RESOLVED → VERIFIED
Posted image screenshot.png
This works with the latest Nightly (build ID: 20130915030208) (while testing it for iteration #14), but I've encountered the next issue:

- while downloading an .exe from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/24.0b10-candidates/build1/win32/en-US/ , the file downloaded as expected, but the blue ring around the download button is only half filled 

Please see the attached screenshot for details.

Does anyone have any suggestions/thoughts? Thanks!
Flags: needinfo?(sfoster)
Manuela, can you create a new issue for this if you can still reproduce it with the latest nightly? We have worked through some problems with the downloads progress ring so this might be covered in an existing ticket, but if you're unsure, file the bug and we'll figure it out.
Flags: needinfo?(sfoster)
(In reply to Sam Foster [:sfoster] from comment #9)
> Manuela, can you create a new issue for this if you can still reproduce it
> with the latest nightly? We have worked through some problems with the
> downloads progress ring so this might be covered in an existing ticket, but
> if you're unsure, file the bug and we'll figure it out.

Everything works as expected now, with the latest Nightly (build ID: 20130918030202) on a Win 8 32-bit machine. I can't reproduce the issue anymore.
You need to log in before you can comment on or make changes to this bug.