Closed Bug 907286 Opened 9 years ago Closed 9 years ago

Implement Frame Counter API for non OMTC basic

Categories

(Core :: Graphics, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla26

People

(Reporter: BenWa, Assigned: BenWa)

References

Details

Attachments

(1 file, 1 obsolete file)

fx-team would like to use the profiler to get a frame-sync profiles on non OMTC basic. This will be easy to port.
Attached patch WIP (obsolete) — Splinter Review
This patch doesn't work on mac because we only copy back the portion of the frame buffer we need back to the window. Can you see if this work on win?
Flags: needinfo?(mconley)
Flags: needinfo?(mconley)
Didn't mean to wipe out the needinfo on myself.
Flags: needinfo?(mconley)
Duplicate of this bug: 908229
Attached patch patchSplinter Review
Assignee: nobody → bgirard
Attachment #793017 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #794106 - Flags: review?(jmuizelaar)
Flags: needinfo?(mconley)
Comment on attachment 794106 [details] [diff] [review]
patch

Review of attachment 794106 [details] [diff] [review]:
-----------------------------------------------------------------

The Graphics parts are fine.
Attachment #794106 - Flags: review?(jmuizelaar) → review+
Comment on attachment 794106 [details] [diff] [review]
patch

tn can you review the nsViewManager part?
Attachment #794106 - Flags: review?(tnikkel)
Comment on attachment 794106 [details] [diff] [review]
patch

Where's the definition of DrawFrameCounter?
(In reply to Timothy Nikkel (:tn) from comment #7)
> Comment on attachment 794106 [details] [diff] [review]
> patch
> 
> Where's the definition of DrawFrameCounter?

http://mxr.mozilla.org/mozilla-central/source/gfx/thebes/gfxPlatform.cpp#1211
Comment on attachment 794106 [details] [diff] [review]
patch

Oh, silly me. I misread the patch and thought you were adding the declaration of DrawFrameCounter in this patch, which you aren't.
Attachment #794106 - Flags: review?(tnikkel) → review+
https://hg.mozilla.org/mozilla-central/rev/b66681223e7c
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
You need to log in before you can comment on or make changes to this bug.