SVG image cropped by too small rectangle

RESOLVED DUPLICATE of bug 736431

Status

()

RESOLVED DUPLICATE of bug 736431
6 years ago
6 years ago

People

(Reporter: ahto.truu, Unassigned)

Tracking

23 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 793083 [details]
An example file affected by the bug.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

An SVG image embedded in a DIV element is cropped to much smaller rectangle than the size of the DIV. Selecting the cropped-out elements in the element inspector indicates their positions are calculated correctly, they are just not displayed.


Actual results:

Only top-left one of the four circles in the image in the enclosed file is visible.


Expected results:

Expected to see all four circles. This is also what happens in all other browsers I have tested with.

Comment 1

6 years ago
It should work if you add “width="600" height="275"” attributes or “style="height: 275px; width: 600px"” to the svg tag instead of the div tag.
(Reporter)

Comment 2

6 years ago
Indeed, it does. Thanks for the workaround.

Comment 3

6 years ago
maybe duplication of Bug 736431
Indeed it is.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 736431
You need to log in before you can comment on or make changes to this bug.