Closed Bug 907441 Opened 6 years ago Closed 6 years ago

[B2G][Buri][1.2][Bluetooth] Bluetooth request form is blank when attempting to pair with another device

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+)

RESOLVED FIXED
blocking-b2g koi+

People

(Reporter: ssuresh, Assigned: gduan)

References

Details

(Keywords: regression, smoketest)

Attachments

(2 files)

Description:
When attempting to pair with another device over bluetooth, Bluetooth request form is blank with only two buttons at the bottom 'pair' and 'cancel' 

Repro Steps:
1) Updated Buri v1.2 to Build ID: 20130820040204
2) Go to settings 
3) Turn on bluetooth and tap to connect to the device
4) Observe that the Bluetooth request form is Blank.

Actual:
Bluetooth request form is blank when attempting to pair with another device

Expected:
Bluetooth request form is not blank and displays a confirmation code

Environmental Variables
Build ID: 20130820040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/bb025b6949e8
Gaia: 7249b5d61b955c23efe9e18f80f0da2e78d827eb
Platform Version: 26.0a1

Notes:
Repro frequency:  100%,
See attached: screenshot, logcat
Component: Bluetooth → Gaia::Bluetooth File Transfer
Attached file logcat for bluetooth
Also user is not able to pair devices because the 'Pair' button is unresponsive, cancel button is unresponsive as well
blocking-b2g: --- → koi?
Component: Gaia::Bluetooth File Transfer → Gaia::Settings
QA Contact: dkumar
QA Contact: dkumar → sparsons
The 8/20 build was the the first build that this issue occurred first. I checked all the builds from June 22nd to today, and the issue was not occurring on any of the previous builds.  

Environmental Variables
Build ID: 20130820040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/bb025b6949e8
Gaia: 7249b5d61b955c23efe9e18f80f0da2e78d827eb
Platform Version: 26.0a1
Ben - The push log shows that you made a lot of changes to bluetooth recently. Any ideas on what regressed here?
Flags: needinfo?(btian)
Recent smoketest report shows this reproducing on 1.1 as well. bug 905558 looks like the candidate for causing this regression.
Blocks: 905558
blocking-b2g: koi? → leo?
(In reply to Jason Smith [:jsmith] from comment #4)
> Ben - The push log shows that you made a lot of changes to bluetooth
> recently. Any ideas on what regressed here?

Given that bug 905558 looks like the candidate now, I'm switching needinfo to Arthur, who implemented bug 905558.
Flags: needinfo?(btian) → needinfo?(arthur.chen)
Bug 905558 fixed a problem of dialer. I think it does not result to this bug. Ben, any ideas?
Flags: needinfo?(arthur.chen) → needinfo?(btian)
I tried build ID 20130819040203 with the latest gaia master and cannot reproduce the bug.
(In reply to Arthur Chen [:arthurcc] from comment #8)
> I tried build ID 20130819040203 with the latest gaia master and cannot
> reproduce the bug.

See comment 3. The bug starting occurring on a 8/20 build, so it makes sense 8/19 did not have the bug present.
No longer blocks: 905558
After had some tests with Ben, this issue was regressed by this commit https://github.com/mozilla-b2g/gaia/commit/125d2e74097c200649375abd446251adf3f2bab9.

We cannot reproduce the bug with the steps as description. However, we found that it can be reproduced after turning off and turning on bluetooth. The root cause was that the event listener of `bluetooth-pairing-request` was added every time the bluetooth adapter becomes available. Although we are not quite sure why it occurs after 8/20 builds. (We can reproduce it using a 8/18 build)
Flags: needinfo?(btian)
> We cannot reproduce the bug with the steps as description. However, we found
> that it can be reproduced after turning off and turning on bluetooth.

The following is our STR:
1) Go to Settings.
2) Turn on bluetooth and tap to connect to the device.
3) Click 'cancel' when the request form shows. This request form displays with confirmation code normally.
4) Turn off bluetooth and then turn it on again.
5) Tap to connect to the same device. The blank request form shows.
Assignee: nobody → arthur.chen
QA Wanted - the regressing commit referenced here points this to being a bug on master only, but the smoketest report indicates this also reproduces on v1-train. Can someone double check what branches this bug can be reproduced on?
blocking-b2g: leo? → koi?
Keywords: qawanted
QA Contact: sparsons
QA Contact: dkumar
Unable to repro on Leo 1.1 commercial RIL.  All attempts to pair devices lead to pairing pages with text visible and buttons functional.

Environmental Variables
Build ID: 20130822041201
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/74914b454b88
Gaia: a83c5fee49525ec0545059b5a56a3fd9f1c09f19
Platform Version: 18.1
RIL Version: 01.01.00.019.199
Hi George, looks like bug 896934 regressed this. Please backout asap, so that QA is unblocked.
Assignee: arthur.chen → gduan
blocking-b2g: koi? → koi+
Removing QAWanted as per comment 14
Keywords: qawanted
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 896934
(In reply to George Duan [:gduan] from comment #16)
> 
> *** This bug has been marked as a duplicate of bug 896934 ***

Actually, if you backout a bug due to a critical regression, this should be marked as fixed by backout of the associated bug.
Resolution: DUPLICATE → FIXED
See Also: → 911611
You need to log in before you can comment on or make changes to this bug.