Closed Bug 907470 Opened 7 years ago Closed 7 years ago

[B2G][Buri][1.2] The buttons are misplaced when user tries to add apps from Everything.me to homescreen

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+)

RESOLVED FIXED
blocking-b2g koi+

People

(Reporter: ssuresh, Assigned: alive)

Details

(Keywords: regression, Whiteboard: [FT:System-Platform])

Attachments

(3 files)

Attached image Screenshot
Description:
When user tries to add Everything.me apps to homescreen through 'add to favourites',the buttons are misplaced and the app's homescreen is still seen in the background

Repro Steps:
1) Updated Buri device to Mozilla v1.2 Build ID: 20130820040204
2) Navigate to Everything.me screen
3) Tap on any app from everything.me screen
4) Then tap on little arrow at the bottom of screen to add to homescreen
5) Observe that the buttons are misplaced

Actual:
The buttons are misplaced when user tries to add everything.me apps to homescreen 

Expected:
The buttons are not misplaced when user tries to add everything.me apps to homescreen 

Environmental Variables
Build ID: 20130820040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/bb025b6949e8
Gaia: 7249b5d61b955c23efe9e18f80f0da2e78d827eb
Platform Version: 26.0a1

Notes:
Repro frequency:  100%,
See attached: screenshot, logcat
Attached file logcat
Alive did a lot of refactoring recently with the wrapper here. Maybe it's a regression from that work?
No longer blocks: b2g-central-dogfood
Component: Gaia::Everything.me → Gaia::System
Keywords: regression
blocking-b2g: --- → koi?
Thanks flagging me, investigating.
Assignee: nobody → alive
Hmm, I cannot reproduce by adding website bookmark to homescreen,
and my ev.me shows nothing now..
I reproduces this on Firefox Aurora. This should be a regression from bug 870747.
Add dialog class to select-one dialog.
Attachment #793809 - Flags: review?(timdream)
Comment on attachment 793809 [details]
https://github.com/mozilla-b2g/gaia/pull/11680

I am not supposed to r+ this part of the code actually but I think this is trivial enough...
Attachment #793809 - Flags: review?(timdream) → review+
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) from comment #7)
> Comment on attachment 793809 [details]
> https://github.com/mozilla-b2g/gaia/pull/11680
> 
> I am not supposed to r+ this part of the code actually but I think this is
> trivial enough...

Never mind, I thought this is about e.me.
Summary: [B2G][Buri][1.2][Everything.me] The buttons are misplaced when user tries to add apps from Everything.me to homescreen → [B2G][Buri][1.2] The buttons are misplaced when user tries to add apps from Everything.me to homescreen
master
https://github.com/mozilla-b2g/gaia/commit/081d3bb5ec45da6fe78b0aa3a99ff61146c11e48
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [FT:System-Platform]
blocking-b2g: koi? → koi+
You need to log in before you can comment on or make changes to this bug.