INC0011757: Phone conference broken

RESOLVED FIXED

Status

Infrastructure & Operations
Telecom
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jbraddock, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
Comments from user------

Lots of issues with a meeting in my conference room this morning:
1. Dialing the 1-800 number got an "all circuits busy" every time
2. Dialing the main Mozilla number, x92, 366# -- nothing would happen. It wouldn't join the conference room, it would just do nothing. Of the participants that actually made it in, all had to redial for 5+ minutes until it worked.
3. Once actually in the conference, audio would cut out every few seconds for between 5 - 20 seconds at a time.

Troubleshooting------

1. Bug 907276 is open to resolve this issue
2. Dialing either 650-903-0800 x92 x366# or 415-762-5700 x92 x366# or x92 x366# sometimes works and other times it does not (mostly does not work). I also get the same results w/ my x.211 performing the same dialing methods.
3. Have not tested this because I was not able to get into a audio only conference room today.

I have also tested x850 on ringring (mtv) and all is working fine - issue looks to be only with pbx1.sfo1. Let me know how I can help troubleshoot.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 907276
Only item #1 in this bug is a dupe of bug 907276, and he already points out that bug in the first comment.  #2 and #3 are a separate issue, probably completely unrelated.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
OK, for me this seems to be working at the moment (tested from a softphone connected to SFO).  I will note that conf room 366 is hosted in Toronto...  it's possible that the Toronto office was having network issues at the time, as those systems seem consistent with intermittent network connectivity...
s/systems/symptoms/
(Reporter)

Comment 5

5 years ago
366 is also hosted in SFO as well. I tested on x211 (hosted in SFO) and received the same results as Comment 0.

@jlin - is 366 still being used in TOR? FYI phonebook does not reflect it is assigned to someone but to Justin Scott.
aha, that'd be or problem then if it's double-assigned
(Reporter)

Comment 7

5 years ago
Right, but even still x211 (my extension) is still not working w/ audio conferencing and to the best of my knowledge the extension is not duplicated on other PBX servers.
what do you mean... can you not dial into conferences from that extension, or people can't call into your extension's conference room?
(Reporter)

Comment 9

5 years ago
Sorry for the confusion, people cannot dial into my extensions conference room. Just tried w/ cell phone and desk phone connected to sfo1.
I don't see any references to 366 in toronto - could it be a typo? or otherwise it could be a vestigial from someone deleted long ago.
note that 336 is in toronto (Jeff Muizelaar) - so it might be a typo'ed grep?
(Reporter)

Comment 12

5 years ago
@justdave - Any update here? Audio conferencing on pbx1.sfo1 is still down and users rely on this service daily (just tested w/ x211 and x366). An ETA would be appreciated. Thanks!
OK, conference rooms 211 and 366 both still existed in Mountain View.  Apparently both of these extensions used to be in MTV and moved to SFO.  The extensions got deleted but the conference rooms didn't.

So SFO would look it up and see that MTV hosted it and send it to MTV, MTV would look it up and see that SFO hosted it and send it back, and it got stuck in a loop.

I've deleted conference rooms 211 and 366 from MTV, and they appear to work now.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

5 years ago
@justdave - thank you much! For some reason I was under the impression that audio conferencing accounts were deleted when an extension is removed from the Asterisks server. I am also going to let my team know of this.
(In reply to Joel Braddock :jbraddock from comment #14)
> For some reason I was under the impression that
> audio conferencing accounts were deleted when an extension is removed from
> the Asterisks server.

It creates them automatically, so it stands to reason that it would nuke them automatically, too, doesn't it?

Actually, there are hooks in the extension delete process that we could hook into.  I bet we could make it delete the conferences at the same time through that.  Bug 908707 filed to try to implement that.
(Reporter)

Comment 16

5 years ago
(In reply to Dave Miller [:justdave] from comment #15)

> It creates them automatically, so it stands to reason that it would nuke
> them automatically, too, doesn't it?
> 
> Actually, there are hooks in the extension delete process that we could hook
> into.  I bet we could make it delete the conferences at the same time
> through that.  Bug 908707 filed to try to implement that.

Correct, if we can delete the conf accounts when deleting extensions, that would be best.
(Reporter)

Comment 17

5 years ago
@justdave: Would you mind checking conf 830 (currently on sfo1) as the same issue is happening. I have checked all ringring linked PBX servers and could not find the conf number 830 used anywhere else. You help would be appreciated.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
london*CLI> dundi lookup 830@conference
  1.     0 IAX2/dundi:qOWVdOLx+HqVudt4mWCoEA==@pbx.sfo1.mozilla.com/***830 (EXISTS)
     from 78:e3:b5:18:01:a4, expires in 3355 s
  2.     0 IAX2/dundi:04dLRmQkiy+MrwsnQwx9fw==@10.250.32.10/***830 (EXISTS)
     from 00:14:38:be:46:93, expires in 60 s
DUNDi lookup completed in 140 ms

That looks like it exists in both places.  The content of that "confrence" context in dundi is created by a cron job, so just deleting it in the GUI doesn't take effect immediately.  Let me go kick the cron.
manually ran the cron job, 830 is gone from mtv1.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Comment 20

5 years ago
thanks! looks like it is now working.
(Reporter)

Comment 21

5 years ago
Thanks Dave!
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.