[Buri][Gallery]The editing picture will be upside-down when rotate the screen

RESOLVED DUPLICATE of bug 907108

Status

Firefox OS
Gaia::Gallery
P1
normal
RESOLVED DUPLICATE of bug 907108
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

258.48 KB, image/x-png
Details
(Reporter)

Description

4 years ago
Firefox os  v1.1
 Mozilla build ID:20130812041203
 
 Created an attachment (id=494880)
 picture
 
 DEFECT DESCRIPTION:
 The editing picture upside-down when rotary screen
 
 REPRODUCING PROCEDURES:
 1.Launch gallery app
 2.Tap a picture and click edit button
 3.Vertical screen rotation of 180 degrees or Horizontal screen rotation of 180 degrees-->the picture upside-down -->ko
 
 EXPECTED BEHAVIOUR:
 ko:the picture will be shows normally when rotary screen,it can't be upside-down
 
 ASSOCIATE SPECIFICATION:
 
 
 TEST PLAN REFERENCE:
 
 
 TOOLS AND PLATFORMS USED:
 
 
 USER IMPACT:
 Mid
 
 REPRODUCING RATE:
 5/5
 
 For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

4 years ago
Clone from brother
(Reporter)

Comment 2

4 years ago
Created attachment 793277 [details]
picture
Interesting bug. I can reproduce it with Leo but not Inari. All of them are tested with the same version of gaia master.
Looks like this bug depends on device. I had check code in gaia. It does not lock orientation on device and does not read the orientation from device to do image editing. So, the UI is handled by gecko layer.

Comment 5

4 years ago
Hi,everyone.Is there any advance?

Comment 6

4 years ago
why image can not remote correctly as mobile remote when Load image into the texture by gl.texImage2D() function? Image as elelment's backgroundimage on interface can remote correctly.
liangxin,

Thanks for bringing this bug up. There is another bug 907108 is really similar to this one. I mark it as duplicated of that one. Since lots people had put their inputs there. You can also test your device with the suggestion there. If you feel it is not a duplicate, please reopen it again.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 907108

Comment 8

4 years ago
(In reply to John Hu [:johnhu] from comment #3)
> Interesting bug. I can reproduce it with Leo but not Inari. All of them are
> tested with the same version of gaia master.

It is very strange that I couldn't reproduce this with my leo device based on latest m-c code base.
Hi Peter, 

I had tested it with an older version, 20130812041203. And that's the version of b2g18.
You need to log in before you can comment on or make changes to this bug.