Unable to set server certificates as untrusted

RESOLVED DUPLICATE of bug 825583

Status

defect
RESOLVED DUPLICATE of bug 825583
6 years ago
3 years ago

People

(Reporter: largeopenroomwithwindows, Unassigned)

Tracking

23 Branch
x86_64
Windows 8

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

On a clean Firefox installation (tried Firefox 17, 22, 23, Windows, Debian):
Firefox -> (Tools) -> Options -> Advanced -> Certificates -> View Certificates -> Servers (tab)

Select any certificate shipped with Firefox, click "Edit Trust". 
The option "Do not trust the authenticity of this certificate" is checked.

Click "OK". Click "Edit Trust" again for the same certificate. Now inexplicably the
"Trust the authenticity of this certificate" radiobox is selected.


Actual results:

No matter which trust option radiobox is selected and how many times I press OK from then on, it now always remains "Trust the authenticity of this certificate" and I can never set it to "Do not trust the authenticity of this certificate" again. In other words the setting has no effect.

The only way I can restore the "Do not trust the authenticity of this certificate" check is to export the certificate, delete it, and re-import it; then this option is checked. However in that case I did not even explicitly tell it to distrust the certificate either; ambiguous.




Expected results:

The selected checkbox setting should be saved and applied.
Component: Untriaged → Security: UI
Product: Firefox → Core

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 825583
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.