[B2G][Helix][Gallery][yangshiqi]enter into gallery ,choose a picture to edit,change screen orientation to horizontal,the picture deteriorate seriously

RESOLVED DUPLICATE of bug 906534

Status

Firefox OS
Gaia::Gallery
P2
normal
RESOLVED DUPLICATE of bug 906534
5 years ago
5 years ago

People

(Reporter: lecky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)

Steps to reproduce:

1.enter into gallery ,choose a picture to edit
2.press edit button(the middle one at the bottom) to lanuch.
3.change the screen orientation into horizontal.


Actual results:

some part of the picture colour became differenct and the quality of picture display baddly


Expected results:

The colour of the picture should not change .
(Reporter)

Updated

5 years ago
blocking-b2g: --- → hd?
Cannot reproduce it with the following build:

gecko: 05853a4c86c59742cc0f62b198a41181672ac83d
gaia: b26e980da9819daaf915f09be7eb0b12f69ba24a
From PVT, 20130828042201
(Reporter)

Updated

5 years ago
Component: General → Gaia::Gallery
Product: Core → Boot2Gecko
(Reporter)

Updated

5 years ago
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86 → All
(Reporter)

Updated

5 years ago
Priority: -- → P1
(Reporter)

Updated

5 years ago
Severity: normal → critical
(Reporter)

Comment 2

5 years ago
(In reply to John Hu [:johnhu] from comment #1)
> Cannot reproduce it with the following build:

gecko:
> 05853a4c86c59742cc0f62b198a41181672ac83d
gaia:
> b26e980da9819daaf915f09be7eb0b12f69ba24a
From PVT, 20130828042201
yeah,we can't reproduce it either in latest version.
this problem is find in 
【Gaia commit ID*】:c0ea0a4943dc8d3751b07f5b5c5d3abe06364a14  
【Gecko commit ID*】: 170f9e477571127cd40997fa2abe262ed43f0e4d 
now , I just want to confirm is that you to fix it?
Lecky, 

I don't really sure what you mean. I didn't fix it. It looks like this is an existing bug in our old version. I had checked the code of gaia, it is at two weeks ago. But it is fixed by some other patches. I don't remember we have the exactly the same bug.
William, can you check this on latest partner image and also with updated Mozilla Gecko/Gaia to confirm this can be closed as WFM?
Flags: needinfo?(whsu)

Comment 5

5 years ago
I can reproduce this bug.
It seems related to jagged problem that Huaweu reported.

Attaching the test image and screenshot(Result)


Test Build:
- PVT Build: Mozilla-b2g18_v1_1_0_hd-helix/2013-09-03-04-22-01
- Gecko revision="dc78e5642c44"
- Gaia revision="d3e3d1e29dc52f038a6cb69a91b57d6cc2622955"
- Gecko version: 26.0a1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(whsu)

Comment 6

5 years ago
Sorry for the typo.

It seems related to jagged problem that Huaweu reported.
->> It seems related to jagged problem that Huawei reported.

Comment 7

5 years ago
Created attachment 799472 [details]
Test image

Comment 8

5 years ago
Created attachment 799473 [details]
Test result
I can reproduce it now. The image is important. It needs blue color in its image to reproduce it. And there is a symptom with black background under the image.
The same image with zoomed in and zoomed out repetitively can reproduce it.
I have no idea about this bug in gaia part.

But if we remove hwcomposer, I can't reproduce it.

a. Search hwcomposer* under system/lib/hw/
b. Rename the library
c. Restart b2g
(Reporter)

Updated

5 years ago
Flags: needinfo?(wchang)

Comment 12

5 years ago
Hi, Vincent,

Do you know how to address this problem?

I cannot sure if you are the right person to help this problem?
If not, please help forward this case.
Many thanks!
Flags: needinfo?(vlin)
Adding Peter 

Peter, given the comments above, it seems to be related to hwcomposer. Perhaps you have some insights?
Flags: needinfo?(wchang) → needinfo?(pchang)
I think this is the color distortion issue caused by HWC. Vlin is helping on this issue.
Flags: needinfo?(pchang)
Is the deterioration only during the transition or does it stay consistently after the rotation has finished?
Flags: needinfo?(wchang)
NI'd the wrong address..
Flags: needinfo?(wchang) → needinfo?(whsu)

Comment 18

5 years ago
It stay consistently after the rotation has finished.

Many thanks!
Flags: needinfo?(whsu)

Comment 19

5 years ago
I think this is a dup. of Bug 906534.
Flags: needinfo?(vlin)
(Reporter)

Updated

5 years ago
Severity: critical → normal
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Priority: P1 → P2
Resolution: --- → WORKSFORME
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED

Updated

5 years ago
Status: VERIFIED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 906534

Updated

5 years ago
blocking-b2g: hd? → ---
You need to log in before you can comment on or make changes to this bug.