Closed Bug 907548 Opened 6 years ago Closed 6 years ago

URL.prototype is not undefined

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26
Tracking Status
firefox25 --- fixed
firefox26 --- fixed

People

(Reporter: bzbarsky, Assigned: bzbarsky)

References

Details

Attachments

(1 file, 1 obsolete file)

Per spec it should be.  This is a regression from bug 813253.
Can we fix the Bindings.conf comments around 'concrete' too please?
With the comment fixes bent asked for
Attachment #793545 - Flags: review?(khuey)
Attachment #793319 - Attachment is obsolete: true
Attachment #793319 - Flags: review?(khuey)
Andrea, you should probably revert this Bindings.conf entry when you land your fix to bug 887364.
Well, presumably any test for bug 887364 would fail without said reversion, so it should be ok.  ;)
https://hg.mozilla.org/integration/mozilla-inbound/rev/52b51dc7c83e
Whiteboard: [need review]
Target Milestone: --- → mozilla26
Comment on attachment 793545 [details] [diff] [review]
URL.prototype should be undefined, since we don't implement the URL API.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 813253
User impact if declined: Some websites might break due to expecting URL API to be
   implemented, when it isn't.
Testing completed (on m-c, etc.): Passes regression tests.
Risk to taking this patch (and alternatives if risky): Pretty small: I doubt
   anyone would expect the prototype to be there in a browser not implementing
   URL API, especially since the spec explicitly forbids it.  The other option is
   to just let this ride the trains for now.
String or IDL/UUID changes made by this patch: None.
Attachment #793545 - Flags: approval-mozilla-beta?
Attachment #793545 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/52b51dc7c83e
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
(In reply to Boris Zbarsky [:bz] from comment #7)
> Comment on attachment 793545 [details] [diff] [review]
> URL.prototype should be undefined, since we don't implement the URL API.
> 
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): Bug 813253
> User impact if declined: Some websites might break due to expecting URL API
> to be
>    implemented, when it isn't.
> Testing completed (on m-c, etc.): Passes regression tests.
> Risk to taking this patch (and alternatives if risky): Pretty small: I doubt
>    anyone would expect the prototype to be there in a browser not
> implementing
>    URL API, especially since the spec explicitly forbids it.  The other
> option is
>    to just let this ride the trains for now.
> String or IDL/UUID changes made by this patch: None.

 Do we know of any websites that are already impacted ?
We do not, no.
In that case, approving this for aurora only at this time.If for some reason we thinkwe should ship this in Fx24 given its ESR as well I am happy to approve for beta as well given the low risk.Feel free to renominate for beta.
Attachment #793545 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #793545 - Flags: approval-mozilla-beta?
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.