Closed Bug 90763 Opened 19 years ago Closed 18 years ago

covert gfx and widget to use NS_GET_MODULE

Categories

(SeaMonkey :: Build Config, defect)

PowerPC
Mac System 9.x
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 94434

People

(Reporter: thesteve, Assigned: sfraser_bugs)

References

Details

Attachments

(2 files)

in gfx.mcp, locale.mcp and widget.mcp, change the following, for all targets:

remove nsGfxFactoryMac.cpp, nsLocaleSHLIB.cpp, and nsWidgetFactory.cpp with the
deprecated NS_GET_FACTORY implementation; add a msGfxModule.cpp, with
NS_GET_MODULE implementation. 

In order to land the static Mac build (which requires this change for its
targets), on the branch, it would be better to already have these changes
working for existing targets on the trunk.
Blocks: 77151
Status: UNCONFIRMED → NEW
Ever confirmed: true
Could you own this bug?
Assignee: karnaze → thesteve
Component: Layout → Compositor
In order to get towards an answer to you, I'm sending mail to shaver, the owner
of the blocking bug (77151), to see how far along he has gotten on the larger
issue.
Bug #93566 has been created to deal with the nsLocale issue. This bug now is for
gfx, widget, and any related nsSetUpRegistry.cpp changes.
Component: Compositor → Build Config
Summary: covert gfx, nsMacLocale, and widget to use NS_GET_MODULE → covert gfx and widget to use NS_GET_MODULE
Blocks: 81373
Reassigning to sfraser, which goes along with Bug#81373, the "blocks" bug I
reassigned to him, over a month earlier.

Today, dougt expressed an interest in this, in the context of fixing the other
"blocks" bug, Bug#77151
Assignee: thesteve → sfraser
Diffs are in bug 94434.


*** This bug has been marked as a duplicate of 94434 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.