Receipt is invalid

VERIFIED FIXED in 2013-09-10

Status

Marketplace
Payments/Refunds
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: tauzen, Assigned: Andy McKay)

Tracking

2013-09-10
Points:
---

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 793421 [details]
receipt-failure.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.57 Safari/537.36

Steps to reproduce:

1. Open marketplace and find "Text him?" app.
2. Purchase it and install app
3. Open it.


Actual results:

Receipt invalid info. See screenshot. Tried reinstalling app from Marketplace and same result. Got the email recipt, although it does not contain app price. I was charged properly on my account.


Expected results:

App should be working normaly.
(Reporter)

Comment 1

5 years ago
Additional question - why is this alert in english?
Priority: -- → P1

Updated

5 years ago
Component: General → Payments/Refunds
(Assignee)

Updated

5 years ago
Assignee: nobody → amckay
Target Milestone: --- → 2013-09-10
Version: 1.0 → 1.3
(Assignee)

Comment 2

5 years ago
(In reply to Krzysztof Mioduszewski from comment #1)
> Additional question - why is this alert in english?

Because the app developer has not localised the alert to the user.
(Assignee)

Comment 3

5 years ago
I'd really like to see what that receipt is. If you have adb connected, you can get all your receipts by doing:

adb pull /data/local//webapps/webapps.json

Then please send me that file, or attach to the bug. Please make the bug confidential if you do that, since it does contain receipts for all your apps, not something you should share.
(Assignee)

Comment 4

5 years ago
No need to send me those receipts, I think its fixed. There was a misconfiguration on our server where it was using the wrong settings file.

https://github.com/mozilla/zamboni/commit/ec2b3f

If this now works for you, please verify.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

5 years ago
Yes it works.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.