Closed Bug 907669 Opened 7 years ago Closed 7 years ago

gaia-unit-tests TEST-UNEXPECTED-FAIL | notifications system/ScreenManager toggleScreen() if screenEnabled is true | expected false to be true

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: RyanVM, Assigned: alive)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

This is currently one of the bugs blocking Gaia unit tests from being unhidden on TBPL.

https://tbpl.mozilla.org/php/getParsedLog.php?id=26813346&tree=B2g-Inbound

b2g_ubuntu64_vm b2g-inbound opt test gaia-unit on 2013-08-21 04:21:07 PDT for push 37a1fbdaa344
slave: tst-linux64-ec2-380

04:25:50     INFO -  gaia-unit-tests TEST-START | toggleScreen()
04:25:50     INFO -  gaia-unit-tests TEST-UNEXPECTED-FAIL | notifications system/ScreenManager toggleScreen() if screenEnabled is true | expected false to be true
04:25:50     INFO -  gaia-unit-tests INFO       | stack trace:
04:25:50     INFO -      Error: expected false to be true
04:25:50     INFO -          at chaiAssert (http://test-agent.gaiamobile.org:8080/common/test/helper.js:30)
04:25:50     INFO -          at get (http://test-agent.gaiamobile.org:8080/common/vendor/chai/chai.js:374)
04:25:50     INFO -          at isTrue (http://test-agent.gaiamobile.org:8080/common/vendor/chai/chai.js:1367)
04:25:50     INFO -          at (anonymous) (http://system.gaiamobile.org:8080/test/unit/screen_manager_test.js:712)
04:25:50     INFO -          at wrapper (http://test-agent.gaiamobile.org:8080/common/test/mocha_generators.js:62)
04:25:50     INFO -          at run (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3709)
04:25:50     INFO -          at runTest (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4081)
04:25:50     INFO -          at (anonymous) (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4127)
04:25:50     INFO -          at next (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4007)
04:25:50     INFO -          at (anonymous) (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4016)
04:25:50     INFO -          at next (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3964)
04:25:50     INFO -          at (anonymous) (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3979)
04:25:50     INFO -          at done (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3700)
04:25:50     INFO -          at (anonymous) (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3712)
04:25:50     INFO -          at (anonymous) (http://test-agent.gaiamobile.org:8080/common/test/mocha_generators.js:46)
04:25:50     INFO -          at wrapper (http://test-agent.gaiamobile.org:8080/common/test/mocha_generators.js:73)
04:25:50     INFO -          at run (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3709)
04:25:50     INFO -          at next (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3973)
04:25:50     INFO -          at (anonymous) (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3984)
04:25:50     INFO -          at (anonymous) (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4932)
04:25:50     INFO -  gaia-unit-tests TEST-PASS  | notifications system/ScreenManager toggleScreen() if screenEnabled is false
04:25:50     INFO -  gaia-unit-tests TEST-END   | toggleScreen()
I'm reproducing the issue, having a look...
Hmm, I touched screen manager in bug 905275. Should be a regression.
Assignee: nobody → alive
Fix unit test fail.
Attachment #793793 - Flags: review?(timdream)
Attachment #793793 - Flags: review?(timdream) → review+
master
https://github.com/mozilla-b2g/gaia/commit/1de4323e840c45a14b719898c92034e90c6341a7
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Still get orange "WindowManager is null" issues...
Hmm, travis was breaking but I don't see tests in screen manager fails in local test...verifying again.
It doesn't fail on current travis builds now.

should file another bug with the intermittent issue, because this bug does not give any logs about the WindowManager problem :)
(In reply to Julien Wajsberg [:julienw] from comment #7)
> It doesn't fail on current travis builds now.
> 
> should file another bug with the intermittent issue, because this bug does
> not give any logs about the WindowManager problem :)

Etienne had told me he has a WIP about that, and would file another bug! \O/
You need to log in before you can comment on or make changes to this bug.