Convert Firefox for Android to Downloads.jsm

RESOLVED DUPLICATE of bug 901360

Status

()

Firefox for Android
Download Manager
RESOLVED DUPLICATE of bug 901360
5 years ago
5 years ago

People

(Reporter: Paolo, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
To inherit the performance and memory gains derived from dropping the SQLite
database for downloads, Firefox for Android should migrate to use Downloads.jsm.

These are the involved files, still using nsIDownloadManager:
  /mobile/android/chrome/content/browser.js
  /mobile/android/chrome/content/aboutDownloads.js
  /mobile/android/chrome/content/downloads.js
  /mobile/android/components/DirectoryProvider.js
  /mobile/android/components/DownloadManagerUI.js
  /mobile/android/components/HelperAppDialog.js
  /mobile/android/modules/Sanitizer.jsm

We're about to enable the use of Downloads.jsm in Desktop Nightly, and later
we will clean up the code (now it is complicated because it supports both
back-ends). You'll be able to use that as an example. If you need more
features from the API, feel free to file new bugs blocking bug 825588.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 901360

Updated

5 years ago
No longer blocks: 851471
No longer depends on: 847863
You need to log in before you can comment on or make changes to this bug.