[Contacts] Facebook contacts numbers do not appear in Message app auto suggestions

RESOLVED DUPLICATE of bug 907740

Status

()

Core
DOM: Device Interfaces
RESOLVED DUPLICATE of bug 907740
5 years ago
5 years ago

People

(Reporter: maat, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Facebook contacts numbers do not appear in auto suggestions
	
**PATH 1**
1) prerequisite: contact list must contain unlinked Facebook contacts with a phone number associated to it
2) open messages app
3) type either the name of a Facebook contact that has a phone number associated to it or the phone number itself

**EXPECTED**
Facebook contact will appear in auto suggestions 	

**ACTUAL** 
Facebook contact does not appear in auto suggestions

---end---

**PATH 2**
1) prerequisite: contact list must contain a local contact with a phone number associated to it that is linked to a Facebook contacts with a phone number associated to it
2) open messages app
3) type the phone number that belongs to the Facebook contact the local contact is linked to

**EXPECTED**
The linked contact will appear in auto suggestions 	

**ACTUAL** 
The linked contact does not appear in auto suggestions

---end---

this was recorded on:

unagi-ICS.
user.master.
Rel0.4.
Sprint12.
B-98.
Gecko-0c057b4.
Gaia-686e308
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?
I suspect this is related to issue described in this comment: https://bugzilla.mozilla.org/show_bug.cgi?id=907752#c4
needinfo ayman to help understand if this is a regression or an enhancement regression(which will not be blocked on for 1.1) ?
Flags: needinfo?(aymanmaat)
(Reporter)

Comment 3

5 years ago
(In reply to bhavana bajaj [:bajaj] from comment #2)
> needinfo ayman to help understand if this is a regression or an enhancement
> regression(which will not be blocked on for 1.1) ?

This is the 1st time i have seen this behavior so i am not in a position to state whether it is a regression or not. That said I always expected that all phone numbers associated to any contact in the contact list irrespective of the contacts origin would appear in the auto suggestions ...and end users would expect this as well. So whether or not this is a regression it need to be addressed as a matter of urgency.
Flags: needinfo?(aymanmaat)
(In reply to ayman maat :maat from comment #3)
> (In reply to bhavana bajaj [:bajaj] from comment #2)
> > needinfo ayman to help understand if this is a regression or an enhancement
> > regression(which will not be blocked on for 1.1) ?
> 
> This is the 1st time i have seen this behavior so i am not in a position to
> state whether it is a regression or not. That said I always expected that
> all phone numbers associated to any contact in the contact list irrespective
> of the contacts origin would appear in the auto suggestions...

Agreed, but the Messages app only knows about the data that is provided by mozContacts
Component: Gaia::SMS → DOM: Device Interfaces
Product: Boot2Gecko → Core
Summary: [messages] Facebook contacts numbers do not appear in auto suggestions → [Contacts] Facebook contacts numbers do not appear in Message app auto suggestions
The root issue is a dup of bug 907740 and likely others as well.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 907740

Updated

5 years ago
blocking-b2g: leo? → ---
You need to log in before you can comment on or make changes to this bug.