Searching for 'Paginas' should find Páginas Amarillas in the lookup tool

RESOLVED FIXED

Status

Marketplace
Admin Tools
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: krupa, Assigned: robhudson)

Tracking

Points:
---

Details

(URL)

(Reporter)

Description

5 years ago
steps to reproduce:
1. Load https://marketplace.firefox.com/lookup/
2. Search for paginas

expected behavior:
Searching for paginas returns both paginas amarillas and Páginas Amarillas

observed behavior:
Searching for paginas doesn't return the app with the accent in its name
(Assignee)

Comment 1

5 years ago
Confirmed insofar as the code isn't using any locale analyzers when searching. The problem is we'd somehow need to know which analyzer to use. If your language is English but you want to find Spanish apps you'd have to tell us that before hand so we pick the right analyzer that knows how to normalize access and use the right stemming, etc.
Why do we need to know the app is Spanish and the user who is running lookup is typing in English?  Just treat á as a, etc, for every word in every (latin) language.

Comment 3

5 years ago
Can we just do a search with *all* of the analyzers? Or if less than a certain threshold of apps are returned (e.g.: less than five apps), perform a second query against more analyzers?
Assignee: nobody → robhudson.mozbugs
Priority: -- → P2
(Assignee)

Comment 4

5 years ago
I'm going to look at this. Elasticsearch has a plugin that can normalize unicode characters and such. I'll install and experiment locally.
(Assignee)

Comment 5

5 years ago
Pull request: https://github.com/mozilla/zamboni/pull/1069

This will need to wait until after 9/3 when we plan to install the necessary ICU plugin on our Elasticsearch nodes.
(Assignee)

Comment 6

5 years ago
This has landed:
https://github.com/mozilla/zamboni/commit/1a9aeca1

To verify: create an app with accents or other unicode characters. Submit and approve the app to make it publicly available. Search for the app without the access or unicode characters and verify that it is included in the search results.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

5 years ago
verified at https://marketplace-dev.allizom.org/search?q=ecrit but searching for elon doesn't find eçrit élon in the lookup tool. so, reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to krupa raj[:krupa] from comment #7)
> verified at https://marketplace-dev.allizom.org/search?q=ecrit but searching
> for elon doesn't find eçrit élon in the lookup tool. so, reopening.

It actually does for me if I refresh the page a few times:

http://f.cl.ly/items/0s0n0I2X0x362N1O1u04/Screen%20Shot%202013-09-04%20at%2011.33.28%20AM.png

Heh
(Assignee)

Comment 10

5 years ago
Yep, forgot about checking the lookup tool. I'm sure it's a simple fix but I'll investigate. Thanks.
(Assignee)

Comment 11

5 years ago
Lookup tool was fine and works for me.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.