[Buri][contacts]The content display abnormally after contact was imported from Hotmail

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Contacts
P1
normal
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

Attachments

(4 attachments)

70.97 KB, image/x-png
Details
8.61 KB, application/x-zip-compressed
Details
log
106.17 KB, application/x-zip-compressed
Details
191 bytes, text/html
Details
(Reporter)

Description

5 years ago
Mozilla build ID:20130806071254
 
 
 Created an attachment (id=495578)
 pic_The content display abnormally
 
 DEFECT DESCRIPTION:
 The content display abnormally after contact was imported from Hotmail
 
 REPRODUCING PROCEDURES:
 Pre:To have a Hotmail account with several contacts available to show/import 
 
 Step: 
 1. Open Contacts app->Tap on the settings icon (gear) in the top right
 corner->Tap on ‘outlook’under import contacts sub heading->The log in
 screen is shown->Introduce a valid user/password->Tap on sign in->select
  a contact(eg: ran zhang)->import
 2. click the contact just be imported->enter in contact details,the
 content of 'company' lost -->KO1
 3. the 'country' which was contained in adress lost-->KO2
 the tag of phone number display abnormally,which should show home tag not
 personal tag-->KO3
 4. the content of 'comments' lost-->KO4
 
 EXPECTED BEHAVIOUR:
 KO1:the content of 'company' should display mormally 
 KO2:the 'country' which was contained in adress should  show normally
 KO3:the tag of phone number display abnormally
 KO4:the content of 'comments' display normally
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 Free test
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 Medium
 
 REPRODUCING RATE:
 5/5
 For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Clone from brother
(Reporter)

Comment 2

5 years ago
Created attachment 793805 [details]
pic_The content display abnormally
(Reporter)

Comment 3

5 years ago
Clone from brother
(Reporter)

Comment 4

5 years ago
Created attachment 793806 [details]
adb log
(Reporter)

Comment 5

5 years ago
Clone from brother
(Reporter)

Comment 6

5 years ago
Created attachment 793807 [details]
log

Updated

5 years ago
blocking-b2g: --- → leo?

Comment 7

5 years ago
ko1, we find the data from hotmail servie dosen't include the company information.
ko2, we has resolve.
KO3: the tag of phone number display is same to the data form hotmail service;
KO4: the data from hotmail servie dosen't include 'comments';

so, the api give error informtion to app;
so, i want to konow:
 Does our api fot hotmail is right? or need other paprameters?
David,

Please assign so we can check if this is even an issue.
Assignee: nobody → dscravaglieri
Flags: needinfo?(dscravaglieri)
(In reply to buri.blff from comment #7)
> ko1, we find the data from hotmail servie dosen't include the company
> information.

So this is okay?

> ko2, we has resolve.

So this is fine now?

> KO3: the tag of phone number display is same to the data form hotmail
> service;

So things are good with this?

> KO4: the data from hotmail servie dosen't include 'comments';

So it's no problem?

These questions aside, this seems like a broken new 1.1 feature (Hotmail contacts import) so blocking and assigning to Jose.
Assignee: dscravaglieri → jmcf
blocking-b2g: leo? → leo+
Flags: needinfo?(dscravaglieri)

Comment 10

5 years ago
(In reply to Andrew Overholt [:overholt] from comment #9)
> (In reply to buri.blff from comment #7)
> > ko1, we find the data from hotmail servie dosen't include the company
> > information.
> 
> So this is okay?
> 
> > ko2, we has resolve.
> 
> So this is fine now?
> 
> > KO3: the tag of phone number display is same to the data form hotmail
> > service;
> 
> So things are good with this?
> 
> > KO4: the data from hotmail servie dosen't include 'comments';
> 
> So it's no problem?
> 
> These questions aside, this seems like a broken new 1.1 feature (Hotmail
> contacts import) so blocking and assigning to Jose.



now, only  ko2 is ok;

ko1,ko3 and ko4 is caused for the wrong data from hotmail.
so, we need to check why the data from hotmail is wrong or if we use the api rightly??

Comment 11

5 years ago
is there any progress about checking the api?
Buri,

Is this specific to hotmail alone? OR are we seeing it with other accounts too?
Flags: needinfo?(sync-1)

Comment 13

5 years ago
yes ,this is specific to hotmail alone.
import from outlook is ok.

Updated

5 years ago
Flags: needinfo?(sync-1)

Comment 14

5 years ago
Hi guys,

Could you share with me the account data you used for testing?

you can send it by private email

thanks
Flags: needinfo?(sync-1)
Flags: needinfo?(buri.blff)
Jose,

Did you get the requested data?

Any finding from your end?
Flags: needinfo?(jmcf)

Comment 16

5 years ago
I didn't get any data. Please could you resend it

thanks
Flags: needinfo?(jmcf)

Comment 17

5 years ago
this is the data from hotmail:


{
         "id": "contact.7d67f629000000000000000000000000", 
         "first_name": "ran", 
         "last_name": "Zhang", 
         "name": "ran Zhang", 
         "is_friend": false, 
         "is_favorite": false, 
         "user_id": null, 
         "email_hashes": [
            "3c117c1379a8c2358a27c33ae0a12471d6325b05649f1a53427628afb607ee26"
         ], 
         "updated_time": "2013-08-27T07:35:47+0000", 
         "birth_day": null, 
         "birth_month": null, 
         "emails": {
            "preferred": "\"1245063940@qq.com\" <1245063940@qq.com>", 
            "account": null, 
            "personal": "\"1245063940@qq.com\" <1245063940@qq.com>", 
            "business": null, 
            "other": null
         }, 
         "addresses": {
            "personal": {
               "street": null, 
               "street_2": null, 
               "city": null, 
               "state": null, 
               "postal_code": null, 
               "region": null
            }, 
            "business": {
               "street": "xinan", 
               "street_2": null, 
               "city": "wuxi", 
               "state": "China", 
               "postal_code": "222000", 
               "region": null
            }
         }, 
         "phones": {
            "personal": "0516 8599 017", 
            "business": null, 
            "mobile": "138 6701 7193"
         }
      }

there is no company information to us.
Flags: needinfo?(buri.blff)

Comment 18

5 years ago
could you share by email the account details. otherwise I will not be able to reproduce.

Comment 19

5 years ago
account:caicaililicaicai@hotmail.com
password:cds3424050024

Updated

5 years ago
Flags: needinfo?(sync-1)

Comment 20

5 years ago
Dear Jose:
we has give the hotmail account and password;

Comment 21

5 years ago
Dear Jose:
  Is there any progress?

Comment 22

5 years ago
hi,

Concerning the company name, it is a field we don't deal with it in the current implementation. I think it is an enhancement but not a bug. With respect to the comment field, the comment fields are not provided by the Live API.

The country name in your account is bad mapped to the state field. See 

http://msdn.microsoft.com/en-us/library/live/hh243648.aspx#user

The carrier info is something we cannot guess from the data web get from the API. 

In an essence, I believe there is nothing blocking in this bug, and IMHO it should not be leo+ .
Moving to 1.3? per comment 22.
blocking-b2g: leo+ → 1.3?

Comment 24

5 years ago
this pr is block pr;

the comment field "employer" is not ok for commpany??

Comment 25

5 years ago
i want to know why the data we get from hotmail is not consist to :

{
   "id": "8c8ce076ca27823f", 
   "name": "Roberto Tamburello", 
   "first_name": "Roberto", 
   "last_name": "Tamburello", 
   "link": "http://cid-8c8ce076ca27823f.profile.live.com/", 
   "birth_day": 20, 
   "birth_month": 4, 
   "birth_year": 2010, 
   "work": [
      {
         "employer": {
            "name": "Microsoft Corporation"
         }, 
         "position": {
            "name": "Software Development Engineer"
         }
      }
   ], 
   "emails": {
      "preferred": "Roberto@contoso.com",
      "account": "Roberto@contoso.com", 
      "personal": "Roberto@fabrikam.com", 
      "business": "Robert@adatum.com",
      "other": "Roberto@adventure-works.com"
   },
   "addresses": {
      "personal": {
         "street": "123 Main St.", 
         "street_2": "Apt. A", 
         "city": "Redmond", 
         "state": "WA", 
         "postal_code": "12990", 
         "region": "United States"
      }, 
      "business": {
         "street": "456 Anywhere St.", 
         "street_2": "Suite 1", 
         "city": "Redmond", 
         "state": "WA", 
         "postal_code": "12399", 
         "region": "United States"
      }
   }, 
   "phones": {
      "personal": "(555) 555-1212", 
      "business": "(555) 111-1212", 
      "mobile": null
   }, 
   "locale": "en_US", 
   "updated_time": "2011-04-21T23:55:34+0000"
}



we don't get 
"work": [
      {
         "employer": {
            "name": "Microsoft Corporation"
         }, 
         "position": {
            "name": "Software Development Engineer"
         }
      }
   ],

Comment 26

5 years ago
if we can get 
"work": [
      {
         "employer": {
            "name": "Microsoft Corporation"
         }, 
         "position": {
            "name": "Software Development Engineer"
         }
      }
   ],

we can use the info "employer"

Comment 27

5 years ago
android can get the "company" info

Comment 28

5 years ago
oh yes, indeed. The decision to make here is if we implement this for v1.1, v1.2 or v1.3.

To be honest is a quite easy enhancement. So, I would let this decision to you guys.
Flags: needinfo?(praghunath)
Flags: needinfo?(buri.blff)

Comment 29

5 years ago
(In reply to Jose M. Cantera from comment #28)
> oh yes, indeed. The decision to make here is if we implement this for v1.1,
> v1.2 or v1.3.
> 
> To be honest is a quite easy enhancement. So, I would let this decision to
> you guys.

Sorry, i don't know how to add the comment fields, hope your suggestion.

If you don't want to merge,  you can give me suggestion, i will change on our code, thanks.
Flags: needinfo?(buri.blff)

Comment 30

5 years ago
I would prefer to do that in our branches. It will be ready by the end of today, tomorrow morning (Spain) at the latest.

Comment 31

5 years ago
thanks.

Comment 32

5 years ago
Created attachment 809181 [details]
12395.html

Please try this patch and get back to me with the results.
Attachment #809181 - Flags: feedback?(buri.blff)

Comment 33

5 years ago
Dear Jose:
   the patch is not ok, there still is no company info in company comment fields;

Updated

5 years ago
Flags: needinfo?(jmcf)

Comment 34

5 years ago
Dear Jose:
   we find the data from hotmail dose't have work info.

Comment 35

5 years ago
Dear Jose:
   we find the data from hotmail dosen't have work info. But the android import contact from hotmail, there is work info.

Comment 36

5 years ago
Dear Jose:
   we find the data from hotmail dosen't have work info. But the android import contact from hotmail, there is work info.

Comment 37

5 years ago
Comment on attachment 809181 [details]
12395.html

the proposed patch is not valid as the compny info is not the in the Contact Object but in the user object.
Attachment #809181 - Flags: feedback?(buri.blff)

Comment 38

5 years ago
Hi guys,

Getting the company info or the Notes is not trivial as it is present on another object (user object). This means that we will need to do an additional query per Contact object, which will imply architectural changes in our Connector components. That IMHO should be postponed to v1.3. Sorry for any inconvenience but I thought it was easier but actually it is not. 

Definetely something for v1.3. 

thanks, best

Updated

5 years ago
Flags: needinfo?(praghunath)
Flags: needinfo?(jmcf)

Updated

5 years ago
Status: NEW → ASSIGNED
jmcf please renominate if you have bandwidth and if the architecture can be reviewed at this stage of 1.3 dev.
Flags: needinfo?(jmcf)
minused per comment 39
blocking-b2g: 1.3? → -

Updated

5 years ago
Flags: needinfo?(jmcf)

Updated

5 years ago
Assignee: jmcf → gtorodelvalle

Comment 41

5 years ago
importing contacts from hotmail is still blocker for end user.
blocking-b2g: - → 1.3?
This is not a regression, so the blocking- decision above still stands. We can certainly look into fixing this though.
blocking-b2g: 1.3? → -
Deleting myself as the assignee since no currently working on it ;-)
Assignee: gtorodelvalle → nobody
Adding to backlog to be properly prioritized. Thanks!
blocking-b2g: - → backlog
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.