Sort patcher configs to make diffs clearer

RESOLVED FIXED

Status

Release Engineering
Release Automation: Other
P3
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: nthomas, Assigned: nthomas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Created attachment 793802 [details] [diff] [review]
[tools] Sort patcher config when writing to disk

We get a lot of churn in the patcher configs because perl's Config::General doesn't enforce any sort order by default, eg http://hg.mozilla.org/build/tools/rev/105800cd997d.

You can turn sorting on if you have v2.40 or later, and we have 2.44, so yay. I've confirmed that changing the config ordering doesn't change the snippets we get for the five patcher configs we use.
Attachment #793802 - Flags: review?(bhearsum)
(Assignee)

Comment 1

5 years ago
Created attachment 793808 [details] [diff] [review]
[tools] one-off sorting of configs

The sort order isn't perfect:
         past-update   22.0b6 23.0b1 betatest releasetest beta
         past-update   23.0b1 23.0b2 betatest releasetest beta
+        past-update   23.0b10 24.0b1 betatest releasetest beta
         past-update   23.0b2 23.0b3 betatest releasetest beta
and similar for the likes of the <23.b10> release block, but it doesn't regress anything in my testing and I'll live with that for the win.

These were all generated with a script that read the config in with the '-SaveSorted => 1' set on the Config::General object, then written straight back out again.
Attachment #793808 - Flags: review?(bhearsum)
(Assignee)

Comment 2

5 years ago
Created attachment 793812 [details] [diff] [review]
[tools] one-off sorting of configs

Upload the right patch.
Attachment #793808 - Attachment is obsolete: true
Attachment #793808 - Flags: review?(bhearsum)
Attachment #793812 - Flags: review?(bhearsum)
Attachment #793802 - Flags: review?(bhearsum) → review+
Attachment #793812 - Flags: review?(bhearsum) → review+
(Assignee)

Comment 3

5 years ago
Comment on attachment 793802 [details] [diff] [review]
[tools] Sort patcher config when writing to disk

https://hg.mozilla.org/build/tools/rev/adc48ae1e242
Attachment #793802 - Flags: checked-in+
(Assignee)

Comment 4

5 years ago
Comment on attachment 793812 [details] [diff] [review]
[tools] one-off sorting of configs

With refreshed mozBeta-branch-patcher2.cfg:
https://hg.mozilla.org/build/tools/rev/917367ef222c
Attachment #793812 - Flags: checked-in+
(Assignee)

Comment 5

5 years ago
Bump looks good in 24.0b6.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Wooot! So much better now. Thank a lot, Nick!
(Assignee)

Comment 7

5 years ago
Turns out the machines used for ESR17 only have version 2.30 of Config::General.
Blocks: 915356
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 8

5 years ago
Created attachment 803606 [details] [diff] [review]
[tools] Test for version of Config::General

Thankfully this version seems to do sane things with ordering even without the pref.
Attachment #803606 - Flags: review?(rail)
Attachment #803606 - Flags: review?(rail) → review+
(Assignee)

Comment 10

5 years ago
Updates for ESR went fine with that.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.