Closed Bug 908044 Opened 9 years ago Closed 9 years ago

Met "You are attempting to build with an unsupported JDK." when building Nexus-4

Categories

(Firefox OS Graveyard :: GonkIntegration, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: allstars.chh, Unassigned)

References

Details

When I am build nexus-4, I got 
"You are attempting to build with an unsupported JDK. ... ", that error is triggered from build/core/main.mk and it's checking my 'java'.

However It's okay when I am building unagi or some other devices.

I suspect Nexus-4 uses a older revision of build/ here.
I just checked in a PR which disables the java checks - https://github.com/mozilla-b2g/platform_build/pull/25 . Try again?
The version of build we're using there is correct. Everything there should be based off the android-4.3_r2.1 tag.
Hi, Michael
Yeah it's working now.

Close this bug.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.