Incorrect display of some PDF files by the integrated PDF viewer.

RESOLVED DUPLICATE of bug 819721

Status

()

Firefox
PDF Viewer
RESOLVED DUPLICATE of bug 819721
5 years ago
5 years ago

People

(Reporter: John Kitz, Unassigned)

Tracking

23 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(firefox22 affected, firefox23 affected, firefox24-, firefox25-, firefox26-)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 793911 [details]
with pdf.js.JPG

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

Go to https://www.sparkfun.com/products/9717 or https://www.sparkfun.com/products/9718 and click on the hyperlink "FTDI Cable Schematic" in the documents section of the page.


Actual results:

The integrated PDF viewer opens a .pdf (duh), albeit garbled (see screenshot in attached file named "with pdf.js.jpg").


Expected results:

Download one of "FTDI 3.3V IO 5V Vcc Cable.pdf" or "FTDI Cable 5V.pdf" from www.sparkfun.com and open it in the Adobe Reader to see what it ought to look like.

Updated

5 years ago
Component: Untriaged → PDF Viewer

Comment 1

5 years ago
gfx.canvas.azure.backends = cairo fixes the problem
Status: UNCONFIRMED → NEW
status-firefox22: --- → affected
status-firefox23: --- → affected
tracking-firefox24: --- → ?
tracking-firefox25: --- → ?
tracking-firefox26: --- → ?
Ever confirmed: true
(Reporter)

Comment 2

5 years ago
Changed gfx.canvas.azure.backends default setting as a work-around. Thanks!!
Not tracking for Fx24 as a)this is not a recent regression b) there is a workaround.

But also needinfo'ing :bdahl here in case he thinks this should be tracked on the pdf.js side and there would be an in product fix that is coming up to resolve the issue without disabling azure.
tracking-firefox24: ? → -
tracking-firefox25: ? → -
tracking-firefox26: ? → -
Flags: needinfo?(bdahl)
(Reporter)

Comment 4

5 years ago
(In reply to bhavana bajaj [:bajaj] from comment #3)
> Not tracking for Fx24 as a)this is not a recent regression b) there is a
> workaround.
> 
> But also needinfo'ing :bdahl here in case he thinks this should be tracked
> on the pdf.js side and there would be an in product fix that is coming up to
> resolve the issue without disabling azure.

I'm obviously not aware of the bug fixing process and criteria that Mozilla uses, but shouldn't it work with the preference set to its default value rather than with a value set by the user as a work-around?
This is a gfx issue, not pdf.js.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(bdahl)
Resolution: --- → DUPLICATE
Duplicate of bug: 819721
You need to log in before you can comment on or make changes to this bug.