Closed Bug 908117 Opened 9 years ago Closed 9 years ago

[B2G][dialer][tongxiao]Could not send out the USSD command when the USSD number is saved in the contacts

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P2)

defect

Tracking

(blocking-b2g:koi+, b2g-v1.2 fixed)

RESOLVED FIXED
blocking-b2g koi+
Tracking Status
b2g-v1.2 --- fixed

People

(Reporter: lecky.wanglei, Assigned: ferjm)

References

Details

Attachments

(1 file, 3 obsolete files)

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; MALC; aff-kingsoft-ciba; .NET4.0C; .NET4.0E; Tablet PC 2.0)

Steps to reproduce:

1.Save the USSD number like *100# , into the contacts.
2.Call the contact which save the USSD number.
3.Check whether  the USSD command  is sended out.


Actual results:

the phone make a ordinary call which phone number is the USSD number.


Expected results:

the phone  send out the USSD command .
Priority: -- → P3
blocking-b2g: --- → hd?
Severity: normal → blocker
Priority: P3 → P2
This is not device specific
Assignee: nobody → ferjmoreno
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: [B2G][Helix][dialer][tongxiao]Could not send out the USSD command when the USSD number is saved in the contacts → [B2G][dialer][tongxiao]Could not send out the USSD command when the USSD number is saved in the contacts
Assignee: ferjmoreno → nobody
Will you solve it?
Attached patch wip (obsolete) — Splinter Review
I still need to do further testing and fix the unit tests, but I'd like to have some feedback in the meantime.
Assignee: nobody → ferjmoreno
Attachment #799422 - Flags: feedback?(etienne)
Attached patch wip (obsolete) — Splinter Review
Now the good one
Attachment #799422 - Attachment is obsolete: true
Attachment #799422 - Flags: feedback?(etienne)
Attachment #799425 - Flags: feedback?(etienne)
Comment on attachment 799425 [details] [diff] [review]
wip

Review of attachment 799425 [details] [diff] [review]:
-----------------------------------------------------------------

Sounds good!
A few small comments below.

BTW, :Rik will be a great reviewer for the final patch :)

::: apps/communications/dialer/js/mmi.js
@@ +17,5 @@
>    _pendingRequest: null,
>  
> +  init: function mm_init(callback) {
> +    if (this._ready) {
> +      callback();

we should check that |callback| is not undefined.

::: apps/communications/dialer/test/unit/mmi_test.js
@@ +14,5 @@
> +}
> +
> +if (!this.MobileOperator) {
> +  this.MobileOperator = null;
> +}

you should use the mocksHelper and you won't need this :)

@@ +36,5 @@
> +    realMobileOperator = window.MobileOperator;
> +    window.MobileOperator = MockMobileOperator;
> +
> +    realMobileConnection = window.navigator.mozMobileConnection;
> +    window.navigator.mozMobileConnection = MockMozMobileConnection;

this neither

@@ +48,5 @@
>  
>    teardown(function() {
> +    window.LazyLoader = realLazyLoader;
> +    window.MobileOperator = realMobileOperator;
> +    window.navigator.mozMobileConnection = realMobileConnection;

this neither
Attachment #799425 - Flags: feedback?(etienne)
 Any update?
Attached patch v1 (obsolete) — Splinter Review
Attachment #799425 - Attachment is obsolete: true
Attachment #801600 - Flags: review?(anthony)
Changing the flag to koi? because this is a generic failure in 1.2( I mean not device specific) and a possible certification blocker for the close future.
Thanks Fernando for fixing it!
blocking-b2g: hd? → koi?
I'll rebase this patch as soon as bug 915038 lands.
Depends on: 915038
Comment on attachment 801600 [details] [diff] [review]
v1

Review of attachment 801600 [details] [diff] [review]:
-----------------------------------------------------------------

The dialer changes look identical to bug 915038. Except for the extra mock_mobile_operator.js. A similar file already exists in apps/system, you should probably use that one.

For the contacts changes, I'm not a peer so you should ask someone else to review it. But since I always have to give my opinion, I'm still giving some comments :)

::: apps/communications/contacts/js/contacts.js
@@ +358,4 @@
>    var callOrPick = function callOrPick(number) {
>      if (ActivityHandler.currentlyHandling) {
>        ActivityHandler.postPickSuccess({ number: number });
> +    } else if (MmiManager.isMMI(number)) {

Could we lazy load MmiManager only now instead of for every launch?

@@ +666,5 @@
>        '/facebook/style/curtain_frame.css',
>        '/contacts/style/status.css',
> +      '/contacts/style/fb_extensions.css',
> +      '/dialer/js/mmi.js',
> +      '/shared/js/lazy_l10n.js'

Why are you loading lazy_l10n.js here?
Attachment #801600 - Flags: review?(anthony)
Attached patch v2Splinter Review
Now that bug 915038 landed, the patch is far more simpler :)
Attachment #801600 - Attachment is obsolete: true
Attachment #807357 - Flags: review?(jmcf)
Duplicate of this bug: 903234
Comment on attachment 807357 [details] [diff] [review]
v2

thanks. now is working ok.

PS: It is better, specially for reviewers to create a GH PR rather than a diff.
Attachment #807357 - Flags: review?(jmcf) → review+
Thanks!

https://github.com/mozilla-b2g/gaia/commit/78a3e2509b979bd226f01f557bdf229fd3faa42e
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
I should have mentioned it earlier but no new tests for this makes me sad :( (http://4.bp.blogspot.com/-Sp4xX4sCmEI/UGCThDfZRpI/AAAAAAAAAkg/CewxrnBjr10/s1600/sad-panda-podiatrist_medium.jpg)
Hi,
  Will this problem be fixed in the v1.1hd?
thank you!
Flags: needinfo?(wchang)
no, it will be considered for v1.2 only.

(In reply to lecky from comment #16)
> Hi,
>   Will this problem be fixed in the v1.1hd?
> thank you!
Flags: needinfo?(wchang)
(In reply to Anthony Ricaud (:rik) from comment #15)
> I should have mentioned it earlier but no new tests for this makes me sad :(
> (http://4.bp.blogspot.com/-Sp4xX4sCmEI/UGCThDfZRpI/AAAAAAAAAkg/CewxrnBjr10/
> s1600/sad-panda-podiatrist_medium.jpg)

Don't be sad mate. Bug 919447 :)
Blocks: 919447
triage: koi+
blocking-b2g: koi? → koi+
Uplifted 78a3e2509b979bd226f01f557bdf229fd3faa42e to:
v1.2: 2acd0dbe4d3d0870e960ab5e087ce520dc97279f
blocking-b2g: koi+ → ---
Duplicate of this bug: 925126
blocking-b2g: --- → koi+
Hi Beatriz:
   As Comment 17, they will not be considered on v1.1 now.
   Do you accept that we do not modify this problem?
Flags: needinfo?(brg)
(In reply to lecky from comment #22)
> Hi Beatriz:
>    As Comment 17, they will not be considered on v1.1 now.
>    Do you accept that we do not modify this problem?
Agree with comment 17. Patch is available for v1.2!
Flags: needinfo?(brg)
Duplicate of this bug: 933868
You need to log in before you can comment on or make changes to this bug.