[B2G][Helix][settings][tongxiao]When insert a sim card which include the FDN number,the call waiting could not be enable.

RESOLVED INVALID

Status

Firefox OS
Gaia::Settings
P2
blocker
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: lecky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; MALC; aff-kingsoft-ciba; .NET4.0C; .NET4.0E; Tablet PC 2.0)

Steps to reproduce:

1. Insert a sim card which include the FDN number.
2. Go into "settings" -> "Call settings".
3. Check  the menu of call waiting .
4. Enable the Call Waiting .




Actual results:

1. There is a excalmatory mark near the string "Call Waiting ".
2. Could not enable the Call Waiting successfully.


Expected results:

1. There is not a excalmatory mark near the string "Call Waiting ".
2. Could enable the Call Waiting successfully.
(Reporter)

Updated

4 years ago
Priority: -- → P2
(Reporter)

Updated

4 years ago
blocking-b2g: --- → hd?
(Reporter)

Updated

4 years ago
Severity: normal → blocker
(Reporter)

Comment 1

4 years ago
 any update?
(Reporter)

Comment 2

4 years ago
Hi,
  Is the FDN the feature of v1.2?
  If this, could you modify the buttons of  forward to be normal in the v1.1 feature ,such as "There is a excalmatory mark near the string "Call Waiting ""?
Flags: needinfo?(wchang)
FDN is enabled on v1.2 as bug 911044 mentions.

FDN enabled SIM restricts supplementary services so it is expected that call waiting settings cannot be altered on an FDN enabled SIM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(wchang)
Resolution: --- → INVALID
(Reporter)

Comment 4

4 years ago
Hi,
  Now I know  FDN is enabled on v1.2.
  But can you remove the excalmatory mark near the string "Call Waiting" in the v1.1hd ?Because the FDN is related with the number which is called out. But the "Call Waiting" is related with the number which is called into.There is no necessary connection with each other.
Flags: needinfo?(wchang)
This will not be changed on v1.1/HD.

Call Waiting setup is done via S/S, which is restricted by FDN. It fails when the device attempts to get call waiting status via S/S, therefore the user should know the displayed status may not be true as set on the network.
Flags: needinfo?(wchang)
(Reporter)

Comment 6

4 years ago
Hi Beatriz:
   
   As comment 5,this will not be changed on v1.1/HD.

   If do not modify this problem,would you accept this ?
   
Thanks!
Flags: needinfo?(brg)
(In reply to lecky from comment #6)
> Hi Beatriz:
>    
>    As comment 5,this will not be changed on v1.1/HD.
> 
>    If do not modify this problem,would you accept this ?
>    
> Thanks!

For TEF this is a new feature not in 1.1 scope(but included in v1.2) so no need to support it in 1.1HD. If you want to include it, please move to branch v1.2.
Flags: needinfo?(brg)
(Reporter)

Updated

4 years ago
blocking-b2g: hd? → ---
(Reporter)

Comment 8

4 years ago
 Hi Beatriz:
   As Comment 5, they will not change on v1.1 now.
   So do you accept this ---- When insert a FDN sim card , There is a excalmatory mark near the string "Call Waiting "?
Flags: needinfo?(brg)
(Reporter)

Comment 9

4 years ago
any update?
(In reply to lecky from comment #8)
>  Hi Beatriz:
>    As Comment 5, they will not change on v1.1 now.
>    So do you accept this ---- When insert a FDN sim card , There is a
> excalmatory mark near the string "Call Waiting "?
Comment 7 meant this is not supported in v1.1, not a bug in v1.1.
Flags: needinfo?(brg)
You need to log in before you can comment on or make changes to this bug.