Closed Bug 90828 Opened 19 years ago Closed 19 years ago

-console option causes Mozilla to ignore Preferences on what windows to open on startup

Categories

(Core Graveyard :: Cmd-line Features, defect)

x86
Windows 98
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 58523

People

(Reporter: tuukka.tolvanen, Assigned: vishy)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2+) Gecko/20010713
BuildID:    2001071304

The -console option on the mozilla command line causes Mozilla to ignore the
Preferences about which windows should open on startup (browser, composer,
mail), and only open the Browser. While the -browser and -mail (etc.) options
should cause the Preferences to be ignored, and do so, the -console option is
not profile-related, so it shouldn't.

Reproducible: Always
Steps to Reproduce:
1. Edit - Preferences - Appearance, "When Mozilla starts up, open" check Mozilla
Mail, uncheck others
2. Exit Mozilla, Start Mozilla without options: Mail opens on startup
3. Exit Mozilla, Start Mozilla with -console option: only Browser opens on
startup (in addition to console)

At step 3, Mail should open, not Browser.
se already filed this bug...
Whiteboard: DUPEME
thx

*** This bug has been marked as a duplicate of 58523 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
.
Status: RESOLVED → VERIFIED
Whiteboard: DUPEME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.