Localize new unified /firefox/new page

RESOLVED FIXED

Status

www.mozilla.org
L10N
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: sgarrity, Assigned: flod)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
The /firefox/new page has a series of updates to display custom content depending on the platform and up-to-date status of the client in Bug 868199.

So far this lives in a pull request on github, and is not merged into master: https://github.com/mozilla/bedrock/pull/1115

Holly (:habber) has confirmed that this is string frozen.

Can l10n work begin on this before it lands in master, so we aren't blocked in pushing to production. It appears that the /firefox/new page is active in 70 locales (!!!).

Cheers.
(Reporter)

Updated

4 years ago
Assignee: nobody → francesco.lodolo
(Assignee)

Comment 1

4 years ago
This is the current l10n status of new.lang
http://l10n.mozilla-community.org/~pascalc/langchecker/?locale=all&website=0&file=firefox/new.lang

The current version of /firefox/new was enabled in bug 881754 and this should be the rewrite rule in use
https://github.com/mozilla/bedrock/commit/a02a633dee4a6a5db180260134e4a197fa7e1d67

I think I should be able to extract the strings without the page being on master, but I see at least two problems.

Testing: how can localizers test the page? I still didn't check the difference in terms of strings, but we need some way to test how the page looks.

Production management: the new page will be using a "new.lang" file, when there's already one for the existing page. This will create some problems: 
* If strings are removed in the new unified template the .lang file can't be pushed until the new page is in production. 
* If the page is pushed to production with the existing (old) new.lang file it will result in a mix of English/localized labels, since the template it's already activated. 
Not sure if I'm just overthinking things.

Comment 2

4 years ago
The unified download page is live on the demo2 server at:

https://www-demo2.allizom.org/en-US/firefox/new/

Flod: Can you extract the strings of the unified /firefox/new/ and compare it with the current /firefox/new/ and see how many new strings have been introduced? 

Also, I assume that cannot go live with the unified download page until all of the new strings have been translated for all of the locales that are current live on /firefox/new/.

I created this spreadsheet that tracks the status of the current (non-unified) /firefox/new/ page and which locales are ready and live. I am seeing 47 locales live for the current /fireox/new/.

https://docs.google.com/a/mozilla.com/spreadsheet/ccc?key=0AhRMMhzzlaRtdFA1U1RRLXJNZENCX0dSdGhpelZndmc#gid=0

What about if we set up demo2 to have the strings automatically updates so that all the work can be previewed on demo2? Given that this page is already partially translated and live in bedrock, I don't think we can go live with it until we are l10n complete. Maybe I am wrong...
(Assignee)

Comment 3

4 years ago
(In reply to Chris More [:cmore] from comment #2)
> Flod: Can you extract the strings of the unified /firefox/new/ and compare
> it with the current /firefox/new/ and see how many new strings have been
> introduced? 

Will do it in the next hours and report back here.

> Also, I assume that cannot go live with the unified download page until all
> of the new strings have been translated for all of the locales that are
> current live on /firefox/new/.

That could be a problem. I would say that we need to get a good part of those locales before going to production, not sure about all thought (it could take some time).

> What about if we set up demo2 to have the strings automatically updates so
> that all the work can be previewed on demo2? Given that this page is already
> partially translated and live in bedrock, I don't think we can go live with
> it until we are l10n complete. Maybe I am wrong...

It would mean having a mixture of English and localized strings, which we should try to avoid.

Comment 4

4 years ago
> It would mean having a mixture of English and localized strings, which we
> should try to avoid.

Yes, that is what I would worry about. Once we get a scope of the strings, I can provide the locales that make up 90% of the traffic to the page as a priority list. Do you wan me to do that now?
(Assignee)

Comment 5

4 years ago
(In reply to Chris More [:cmore] from comment #4)
> Yes, that is what I would worry about. Once we get a scope of the strings, I
> can provide the locales that make up 90% of the traffic to the page as a
> priority list. Do you wan me to do that now?

I think we have time for that once localization has started ;-)
(Assignee)

Comment 6

4 years ago
Created attachment 794211 [details]
New strings

From a quick first check it seems there are no removed strings, and 16 new strings. I hope to have SVN ready before the weekend for localizers.

As I commented in the PR, I think we lost an important part, i.e. the possibility to localize the title and meta tag of the page (bug 891761).
https://github.com/mozilla/bedrock/pull/1115#issuecomment-23117939
(Assignee)

Comment 7

4 years ago
(In reply to Francesco Lodolo [:flod] from comment #6)
> As I commented in the PR, I think we lost an important part, i.e. the
> possibility to localize the title and meta tag of the page (bug 891761).
> https://github.com/mozilla/bedrock/pull/1115#issuecomment-23117939

Never mind, I checked the wrong base-resp.html template and the page is working as expected on demo server.
(Assignee)

Comment 8

4 years ago
Strings pushed to locales in r119265. New strings were actually 15.

I'll send a message to dev-l10n-web tomorrow morning to explain how to properly test the page.
(Assignee)

Updated

4 years ago
Depends on: 908660
(Assignee)

Updated

4 years ago
Depends on: 908663
(Assignee)

Comment 9

4 years ago
Quick update.

Based on the rewrite rule, the /new page was enabled for 47 locales. We currently have 21 locales with a complete localization, including one new locale (nb-NO), and still 27 missing. 

I think we'll need at least another week to have a better situation and evaluate if we can activate the page.

Comment 10

4 years ago
(In reply to Francesco Lodolo [:flod] from comment #9)
> Quick update.
> 
> Based on the rewrite rule, the /new page was enabled for 47 locales. We
> currently have 21 locales with a complete localization, including one new
> locale (nb-NO), and still 27 missing. 
> 
> I think we'll need at least another week to have a better situation and
> evaluate if we can activate the page.

Ok, thanks. We will check in next to wee to see how far we are at with the 15 strings for the 47 locales.

Updated

4 years ago
Depends on: 910202
(Assignee)

Comment 11

4 years ago
Another update.

Complete locales at the moment: 30 (covering about 64% of our l10n users).

New locales: 2 (br, nb-NO)

Missing locales compared to previous /new page: 19 (bg, cy, eo, es-CL, es-MX, gd, hr, id, lij, lt, lv, ml, mr, my, pl, pt-BR, te, tr, uk). 

I've just sent a message to dev-l10n-web hoping that we can get this number down.

Comment 12

4 years ago
(In reply to Francesco Lodolo [:flod] from comment #11)
> Another update.
> 
> Complete locales at the moment: 30 (covering about 64% of our l10n users).
> 
> New locales: 2 (br, nb-NO)
> 
> Missing locales compared to previous /new page: 19 (bg, cy, eo, es-CL,
> es-MX, gd, hr, id, lij, lt, lv, ml, mr, my, pl, pt-BR, te, tr, uk). 
> 
> I've just sent a message to dev-l10n-web hoping that we can get this number
> down.

Ok, thanks. what is your estimate on when we could be string complete on the new strings introduced by the unified project?
(Assignee)

Comment 13

4 years ago
It's kind of hard to give an estimation for smaller locales, I hope to have at least the bigger ones (e.g. pt-BR, pl) ready this week.

I think next week we'll have to decide if we want to display a page partially localized or fallback to the old one (removing the rule in htaccess).
(Assignee)

Comment 14

4 years ago
(In reply to Francesco Lodolo [:flod] from comment #13)
> I think next week we'll have to decide if we want to display a page
> partially localized or fallback to the old one (removing the rule in
> htaccess).

As a side note, before that we need to fix the layout issues described in the bugs blocking this one.

Comment 15

4 years ago
(In reply to Francesco Lodolo [:flod] from comment #14)
> (In reply to Francesco Lodolo [:flod] from comment #13)
> > I think next week we'll have to decide if we want to display a page
> > partially localized or fallback to the old one (removing the rule in
> > htaccess).
> 
> As a side note, before that we need to fix the layout issues described in
> the bugs blocking this one.

I agree. I've asked Mike from Silver Orange to check them out. thanks

Updated

4 years ago
Depends on: 891362

Comment 16

4 years ago
Flod: What is the status of the additional strings that need to be translated and in place to be able to go to production with the unified page?
Flags: needinfo?(francesco.lodolo)
(Assignee)

Comment 17

4 years ago
Complete locales: 33 (about 69% coverage of our population). 

We're still missing a couple of big locales (pl, pt-BR). If we can get those done, I believe we are in a good place to start deploying the new page. I'll see with Pascal today how we can get those two locales to react.
Flags: needinfo?(francesco.lodolo)
(Assignee)

Comment 18

4 years ago
Talked with Pascal: we should probably target the beginning of the next week (i.e. Monday or Tuesday) to enable this page on production. 

In the meantime I'll send another message to the mailing list and try to get at least Polish and Brazilian Portuguese done.

Note to self: we'll need to update the redirect rules for new locales (at the moment 'br' and'nb-NO').
49 locales done that represent about 92% of our l10n userbase. probably a bit more actually since we redirect to mozilla.jp for the download page and that bug doesn't apply to them. I think we are good for prod, we will get the last locales over time, most of them are very small locales.
(Assignee)

Updated

4 years ago
Depends on: 917708

Comment 20

4 years ago
The updated /firefox/new/ page is live on production!

Comment 21

4 years ago
New locales will go live as L10N marks them as ready. Thanks everyone for the teamwork!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.